AR 1.14 oracle_adater.rb does not work


#1

the error is :
wrong number of arguments (1 for 0)
where :
active_record/connection_adapters/oracle_adapter.rb:53:in
`attributes_with_quotes_pre_oracle’

this method is new, it was an alias in the previous version :
alias :attributes_with_quotes_pre_oci :attributes_with_quotes
#:nodoc:

I replaced the method by the alias of the previous version, and it is
working fine.
This is the code (s/oci/oracle/) :
alias :attributes_with_quotes_pre_oracle :attributes_with_quotes
#:nodoc:


#2

Jean-Jacques Mahe wrote:

the error is :
wrong number of arguments (1 for 0)
where :
active_record/connection_adapters/oracle_adapter.rb:53:in
`attributes_with_quotes_pre_oracle’

this method is new, it was an alias in the previous version :
alias :attributes_with_quotes_pre_oci :attributes_with_quotes
#:nodoc:

I replaced the method by the alias of the previous version, and it is
working fine.
This is the code (s/oci/oracle/) :
alias :attributes_with_quotes_pre_oracle :attributes_with_quotes
#:nodoc:

I am also having problems with the Oracle adapter. I followed the
instructions from the book Rails Recipes on connecting to multiple
databases. The primary database I am using is MySQL and the secondary
is Oracle. I have a base class defined like this:

class ConferenceBase < ActiveRecord::Base
establish_connection :conference
end

A few other model classes then inherit from this class. As of Rails 1.0
this seemed to work. Now I get the following error when I use the
inherited models:

ORA-04043: object conference_bases does not exist

C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/connection_adapters/oracle_adapter.rb:541:in
object_info' (eval):3:inobject_info’
C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/connection_adapters/oracle_adapter.rb:365:in
columns' C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:696:incolumns’
C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:704:in
columns_hash' C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:1817:indefine_read_methods’
C:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.0/lib/active_record/base.rb:1769:in
method_missing' #{RAILS_ROOT}/app/views/projects/_form.rhtml:41:in_run_rhtml_projects__form’

Can anyone confirm this error?

-Jason


#3

A patch has been posted already, waiting for it to be applied.