Application.rhtml ignored


#1

Hi,

I’m stuck. I have an application that’s been working fine. I made some
changes to the database schema and rebuilt my models, ensuring that I
did not overwrite any of the existing controller or view files. Now,
whenever I display any of my pages, the layouts/application.rhtml file
is completely ignored. I have no idea what’s causing this, and
neither do I have any idea what to do from here. Can anybody offer any
suggestions?

Thanks,

-stan


#2

Stan McFarland wrote:

Hi,

I’m stuck. I have an application that’s been working fine. I made some
changes to the database schema and rebuilt my models, ensuring that I
did not overwrite any of the existing controller or view files. Now,
whenever I display any of my pages, the layouts/application.rhtml file
is completely ignored. I have no idea what’s causing this, and
neither do I have any idea what to do from here. Can anybody offer any
suggestions?
Are there any other files in the layouts/ directory?


#3

Alex Y. wrote:

Stan McFarland wrote:

Hi,

I’m stuck. I have an application that’s been working fine. I made some
changes to the database schema and rebuilt my models, ensuring that I
did not overwrite any of the existing controller or view files. Now,
whenever I display any of my pages, the layouts/application.rhtml file
is completely ignored. I have no idea what’s causing this, and
neither do I have any idea what to do from here. Can anybody offer any
suggestions?
Are there any other files in the layouts/ directory?

D’oh! Forgot about the class-specific files being created. Thanks a
bunch.

-stan


#4

Stan McFarland wrote:

is completely ignored. I have no idea what’s causing this, and
neither do I have any idea what to do from here. Can anybody offer any
suggestions?

Are there any other files in the layouts/ directory?

D’oh! Forgot about the class-specific files being created. Thanks a
bunch.
No worries :slight_smile: