Application error Rails application failed to start properly"

I’ve been strugling for days trying to resolve this issue installing
a rails project on a hosted server. I keep getting
Application error
Rails application failed to start properly"
when I go to front page of my site.
I followed instructions on this thread
http://wiki.ocssolutions.com/Troubleshooting_a_Ruby_on_Rails_Application
and still no luck
I checked dispatch.* for proper ruby line, and permissions 755, I
tried running dispatch.* from shell with this result
Code:

Status: 404 Not Found
Cache-Control: no-cache
Content-Length: 606

Action Controller: Exception caught body { background-color: #fff; color: #333; }
body, p, ol, ul, td {
  font-family: verdana, arial, helvetica, sans-serif;
  font-size:   13px;
  line-height: 18px;
}

pre {
  background-color: #eee;
  padding: 10px;
  font-size: 11px;
}

a { color: #000; }
a:visited { color: #666; }
a:hover { color: #fff; background-color:#000; }

Routing Error

No route matches "" with {:method=>:get}

I tried script/console and got a successfull connect to db, so I know
that is not the problem. fastcgi.log says
[07/Jan/2008:10:04:03 :: 20987] starting
[07/Jan/2008:10:04:03 :: 20987] stopping gracefully

not sure what else to try… any ideas please
Reply With Quotey With Quote

On 1/15/08, slava [email protected] wrote:

Routing Error

No route matches "" with {:method=>:get}

You need to modify config/routes.rb and add a default route.

I used to host with OCS, email them, they will help you. Unlike a lot
of other Rails hosts they actually develop Rails apps, so they know a
lot about it.


Greg D.
http://destiney.com/

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs