API Suggestion


It’s not intuitive to have two hashes on any one method call. Most of
the view helpers have a hash for method options followed by a hash for
html options. I find it to be problematic at best. I think it would be
best to have one hash and then add your html options as a hash entry.
For example:

<%= link_to “All Facilities”, {:action => ‘fac_log_all’}, {:target =>
‘_new’} %>

would become

<%= link_to “All Facilities”, :action => ‘fac_log_all’, :html =>
{:target => ‘_new’} %>

Or even better, any options that are not recognized by the method are
automatically treated as html options:

<%= link_to “All Facilities”, :action => ‘fac_log_all’, :target =>
‘_new’ %>

I’ve seen some examples done both ways, but whatever it is it should be