Apche + SSL Configuration Issue


#1

Hi,

I am trying to setup the SSL for my site. i am using apache as
webserver and mongrel cluster as application server and Ubuntu as
server OS.

I have configured my apache server for the SSL setup as per the
certificate files i got from Go daddy.

I configure apache server according to below link.

http://www.williambharding.com/blog/rails/ultimate-guide-to-setup-ssl-on-rails-and-apache-2-with-ubuntu-seasoning/

After configuring all the things and restarting apache when i am
hitting url in browser as “Network Timeout” with page load error.

Checking at apache error log getting error as "caught SIGWINCH,
shutting down gracefully
Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.1 with Suhosin-Patch mod_ssl/
2.2.8 OpenSSL/0.9.8g configured – resuming normal operations
"

Checking the application log getting error as “Filter chain halted as
[#<ActionController::Filters::ClassMethods::SymbolFilter:0xb73433a4
@filter=:ensure_proper_protocol>] returned_false.”

Does anyone come across same issue ?

Thanks in Adavance.

Piyush.


#2

Do you have this in your Apache server virtual host file?

RequestHeader set X_ORIGINAL_PROTOCOL ‘https’

Mongrel, by design, does not do SSL. Redirects from inside the cluster
will perforce become http. I do not know if this is your issue or not
but it might be a place to start.

Good luck and please report back how you solve it.


#3

James B. wrote:

Do you have this in your Apache server virtual host file?

RequestHeader set X_ORIGINAL_PROTOCOL ‘https’

Opps. I forgot to add this:

http://blog.innerewut.de/2006/6/21/mongrel-and-rails-behind-apache-2-2-and-ssl


#4

James is on to something but you could also remove mongrel from the
mix and just test a plain html or gif. How do you have it configured
between apache and mongrel? ProxyPass ? Do you have the ssl plugin
installed?


#5

Yes James i already added this line RequestHeader set
X_ORIGINAL_PROTOCOL ‘https’. but getting same issue…

On Nov 21, 1:57 am, James B. removed_email_address@domain.invalid


#6

i have installed ssl_requirement plugin in my application. i have
mongrel cluster and apache configuration installed.


#7

On Tue, Nov 25, 2008 at 6:08 AM, Piyush with Rails
removed_email_address@domain.invalid wrote:

Can anyone tell me how to find out the ssl is installed here?

Your apache’s bin directory includes apachectl – run it without any
args to get a list of args; you’ll probably be interested in trying
several
of them ( -l, -t for instance).

HTH,

Hassan S. ------------------------ removed_email_address@domain.invalid


#8

Hey, i tried with various ways doing apache configuration for ssl and
still same issue persist. i feel that i do not have mod_ssl installed
or its not matching with my apache version. i am not sure about i have
installed mod_ssl or not and not able to find it out also.

some of the thins i got related with mod_ssl in my system is given
below.

I have /usr/lib/apache2/modules/mod_ssl.so file here. i have mod_ssl
module enabled in apache.

I have ubuntu flavour of linux and my apache version is 2.2.8.

Right now my site is up without ssl and configuring apache with ssl
giving me this error:

“caught SIGWINCH, shutting down gracefully
Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.1 with Suhosin-Patch mod_ssl/
2.2.8 OpenSSL/0.9.8g configured – resuming normal operations”

Can anyone tell me how to find out the ssl is installed here?

What is going wrong here and need to be done to get ssl work?

Thanks,
Piyush.