Apache2.2 avec module Proxy Balancer: erreur "undefined symb

Après mes différents soucis avec Capistrano et Subversion, voilà encore
une magnifique journée puisque je tâche de passer d’Apache2 à Apache2.2
sur un serveur test afin de tester le module proxy_balancer.

J’avais installé Apache 2.0.54 via la commande “apt-get install
apache2”. J’ai installé Apache 2.2.3 par dessus, en compilant la source
disponible en téléchargement sur apache.org:

|# wget http://apache.scarlet.be/httpd/httpd-2.2.3.tar.gz
# tar -xvzf httpd-2.2.3.tar.gz
# cd httpd-2.2.3
# ./configure --prefix=/etc/apache2 --enable-mods-shared=all 

–enable-deflate --enable-proxy --enable-proxy-balancer
–enable-proxy-http
# make
# make install|

Ensuite, j’ai ajouté la ligne suivante au fichier
/etc/apache2/httpd.conf:

LoadModule proxy_balancer_module modules/mod_proxy_balancer.so

Puis je lance le serveur, et là , l’erreur du jour:

# apache2ctl -k start
Syntax error on line 8 of /etc/apache2/httpd.conf:
Cannot load /etc/apache2/modules/mod_proxy_balancer.so into server:
/etc/apache2/modules/mod_proxy_balancer.so: undefined symbol:
proxy_hook_post_request

Ma recherche sur Google fut particulièrement infructueuse. Je reviens
donc à nouveau vers vous… :\ Quelqu’un aurait-il eu le même souci ou
saurait-il me diriger vers la solution? (en fait je devrais plutôt
poster sur une liste consacrée à Apache2 mais je pense que ça
intéressera du monde par ici…)

Bonne journée à tout le monde,

Michael

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs