Apache/SSL configure error

Hi,

I am attempting to configure Apache 2.2.4 with SSL on Solaris 9 (using
OpenSSL vers 0.9.8e), and getting the following:

checking openssl/engine.h usability… yes
checking openssl/engine.h presence… yes
checking for openssl/engine.h… yes
checking for SSLeay_version in -lcrypto… no
checking for SSL_CTX_new in -lssl… no
checking for ENGINE_init… no
checking for ENGINE_load_builtin_engines… no
checking for SSL_set_cert_store… no
configure: error: … Error, SSL/TLS libraries were missing or unusable

I am running the following configure options

./configure
–with-ssl=/usr/local/ssl
–enable-ssl
–prefix=/usr/local/apache2 \

Also, I have my LD_LIBRARY_PATH=/usr/local/ssl/lib.

I’ve tried reinstalling OpenSSL…no errors during installation.

Any suggestions?

TIA

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs