Apache/Mongrel Cluster - What's this?

I’ve just set up a server with Apache 2.2, mod_proxy_balancer, and a
pack of Mongrels. I’m seeing something I haven’t seen before with this
setup. Here’s an example:

Processing StoriesController#index (for 80.129.122.251 at 2007-02-21
08:38:10) [GET]

[…]

Processing StoriesController#index (for ::1 at 2007-02-21 08:38:14)
[GET]

[…]

These are both for a single request.

It doesn’t happen on every request, even from the same client.

When it does, there’s a consistent 3-to-4 second delay between them.
Looks nasty in the browser:-)

Can anybody point me in the right direction?

Thanks!

–Al Evans

If you’re referring to the ::1 address, that’s IPv6 notation. The
internet’s not quite running on that yet, but your local network might
be :wink:

I’d disable / turn that off for now. Sorry no links on that, what linux
flavor?

On 2/21/07, Al Evans [email protected] wrote:

Processing StoriesController#index (for ::1 at 2007-02-21 08:38:14)


Charles Brian Q.
self-promotion: www.seebq.com
highgroove studios: www.highgroove.com
slingshot hosting: www.slingshothosting.com
main: 678.389.9462 fax: 678.826.0969

Ruby on Rails Bootcamp at the Big Nerd Ranch
Intensive Ruby on Rails Training:
http://www.bignerdranch.com/classes/ruby.shtml

Charles Brian Q. wrote:

If you’re referring to the ::1 address, that’s IPv6 notation.

I guess I wasn’t clear. Yes, I’m aware that ::1 is IPv6 for “localhost”.

What I’m wondering about is why a single request would get sometimes two
responses, separated by 3-4 seconds. I’m sure I must have something
wrong (though I’ve used substantially the same config on another server
with no problems). But I don’t have a clue where to start looking.

I’d disable / turn that off for now. Sorry no links on that, what linux
flavor?

Fedora Core 5.

–Al Evans

Just thought I’d follow up, in case anybody else runs into this problem.

I checked my config, and IPv6 was not enabled on the server.

After scrounging around a bit in Apache documentation, I changed

listen *:80

to

listen :80

That seems to have taken care of it.

–Al Evans

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs