Anyone use JEdit on Windows?

I’ve been playing with various editors for working with Ruby and I
like JEdit so far with the right plugins, etc… But I am having a bit
of a weird problem: I can’t seem to tell the console to associate *.rb
files with the ‘ruby’ command so that I can use the “run current
buffer” option if I manually type ‘ruby test.rb’ into the console, it
runs my test file fine). Also, autocompletion isn’t working.
Everything I’ve read seems to imply that auto-completion should work
right out of the box with the ruby plug-in.

If it helps, I’m on Windows XP, running JEdit version 4.3pre12. The
Ruby plugin seems to be version 0.9. I’ve got Console 4.3.6 installed
and a ton of others. I’m not sure what other information I might need
to include to be helpful.

Sorry, all, if this is a bit off topic. Hopefully those who have no
interest in using JEdit to edit ruby will skip this thread. Thanks
much.

Ben

Don’t use JEdit. But I wonder associate .rb/.rbw files with ruby
interpreter in Windows Explorer help? I think the one-click installer
will do this job for you automatically if you use it.

2008/2/6, Day [email protected]:

On Feb 6, 2008 6:04 AM, Day [email protected] wrote:

autocompletion isn’t working.
Everything I’ve read seems to imply that auto-completion should work
right out of the box with the ruby plug-in.

I’m the author of the Ruby plugin. There used to be naive completion
of method names for the core classes. However I found that it wasn’t
that useful, and took it out of the plugin. Instead I use the Edit ->
Complete Word to complete words that I have already used in the same
file. I also have a keybinding to toggle open the Ruby Docs view,
which allows you to search the Ruby docs for Ruby core and for Rails.

Regards,
Rob

Hello,

… I can’t seem to tell the console to associate *.rb
files with the ‘ruby’ command so that I can use the “run current
buffer” option

Locate:
…\macros\Misc\Run_Script.bsh

(it’s in jEdit home dir or jEdit settings dir)

and look if there is something like this in Run_Script.bsh:

else if(mode.equals(“ruby”)) {
execScript(“ruby”, "ruby -w " + path);
}

If not, try adding these lines and restart jEdit.

– Axel