Any word on a recent build for Win32/Rails 1.2.1


#1

Hi, I am developing on Win XP at the moment for an NGO that seems stuck
on the idea that Win2003 Server is the future. Much as I have tried to
convert them to a unix environment, they’re having none of it.

I am using the prebuilt Win32 release of ferret 0.10.9 and would like to
upgrade to the latest version for the latest features etc but more
importantly to solve an issue with bug reporting in Rail 1.2.1 which
seems to be braking when ferret is required and included (well this is
at least the case when using ferret from /script/runner).

When I require and include ferret any bugs (even those unrelated to
ferret) fail to be reported correctly with messages that start:

…active_support/dependencies.rb:423:in `remove_const’: cannot remove
Object:: (NameError)

Where are things like QueryParser, Field etc.

I have tried compiling ferret myself but I only have mingw installed and
the ferret rails task seems to want to use nmake (MVC?).

Thanks, Chad.