[ANN] Warbler 0.9.12 released, includes JRuby 1.1.6


#1

Hello JRubyists,

I finally got around to releasing the next version of Warbler. I try
to keep pace with JRuby releases but 1.1.5 had some bugs that I wanted
to wait out. As many of you know, Warbler uses a bundled copy of the
jruby complete jar (available in multiple versions here 1). If you
find yourself wanting to only upgrade JRuby, you can easily swap out a
different version in the warbler/lib directory where the gem (or
plugin) was installed. A full list of changes follows.

Thanks for trying Warbler!

/Nick

Changes:

0.9.12

  • Allow framework auto-detection to be disabled. Set
    Warbler.framework_detection = false at the top of config/warble.rb
    or uncomment the line from a newly generated config.
  • Add configuration option to set manifest file (thanks Tommy McGuire)
  • Mitigate RubyGems 1.3 compatibility issue (thanks Jens Norrgrann)
  • Add experimental war:exploded task. This allows you to deploy your
    application in an exploded mode, thus allowing continual development
    without re-warring and re-deploying. Feedback is appreciated if you
    try this feature; it may not work in all application servers and for
    applications other than Rails.
  • Handle Rails gem dependencies better (thanks Laszlo Bacsi)
  • Auto-detect Merb dependencies (Merb >= 1.0 only). Please give
    feedback if you try Warbler with a Merb 1.0 app.
  • Ignore gem development dependencies
  • Upgrade to JRuby 1.1.6 and JRuby-Rack 0.9.3

To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email