[ANN] Sphincter 1.1.0 Released

Sphincter version 1.1.0 has been released!

Sphincter uses Dmytro Shteflyuk’s sphinx Ruby API and automatic
configuration to make totally rad ActiveRecord searching. Well, you
still have to tell Sphincter what models you want to search. It
doesn’t read your mind.

When updating to 1.1.0, run:

rake sphincter:setup_sphinx

Changes:

1.1.0 / 2007-08-13

  • 2 major enhancements:

    • Fields across relationships may be included via add_index.
    • Sphincter now automatically configures Dmytro Shteflyuk’s sphinx
      API. Run
      rake sphincter:setup_sphinx and check in vendor/plugins/sphinx.
  • 1 bug fix:

    • rake sphincter:index task didn’t correctly run reindex. Bug
      submitted
      by Lee O’Mara.
  • http://seattlerb.org/Sphincter


Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. – Syndicate Wars

You really should consider coming up with a different name for your
project.


Michael W.

On Aug 13, 2007, at 22:50, Michael W. wrote:

You really should consider coming up with a different name for your
project.

No. It is the best name ever.


Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. – Syndicate Wars

I agree, awesome name :slight_smile:

Michael W. wrote:

You really should consider coming up with a different name for your
project.


Michael W.

Wait till someone comes up with a project called… open orifice

On Sep 18, 2007, at 13:22, Snaga wrote:

Does Sphincter require Rails 1.2? I am hoping to use it, but I am
stuck with rails 1.1.6 for now.

I’ve never tested it on Ruby 1.1.6. It might work, but I set the
dependency to 1.2.3 because I’m sure it works there.

When updating to 1.1.0, run:
API. Run
Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. – Syndicate
Wars


Poor workers blame their tools. Good workers build better tools. The
best workers get their tools to do the work for them. – Syndicate Wars

Does Sphincter require Rails 1.2? I am hoping to use it, but I am
stuck with rails 1.1.6 for now.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs