[ANN] SimpleAWS 1.2 - Simple and Forward Compatible AWS Library

What is it?

A thin, simple, forward compatible Ruby wrapper around the various
Amazon Web Service APIs that won’t get in your way.

What’s changed?

Added the following API wrappers:

  • DynamoDB
  • Security Token Service (STS)
  • SimpleDB

Re-enabled testing on Java and Rubinius now that nokogiri has new
releases!

Why?

All of the existing AWS Ruby libraries suffer from two fatal issues:
they are overly complex and they aren’t forward compatible. Amazon is
constantly updating their API with new actions, new parameters, new
features, and entire APIs. Shouldn’t you be using an AWS library that
works with this rapid update process?

Quit fighting your library. SimpleAWS is completely forward compatible
with whatever changes Amazon may make to their API and lets you work
directly with Amazon’s own documentation.

Install

Command line:

gem install simple_aws

Bundler:

gem “simple_aws”, “~> 1.2.0”

Runs on 1.8.7, 1.9.2, 1.9.3, MRI-HEAD, JRuby and Rubinius!

Info

Documentation:
http://rubydoc.info/github/jameskilton/simple_aws/master/frames

Source: https://github.com/jameskilton/simple_aws

Issues: https://github.com/jameskilton/simple_aws/issues

Travis CI: http://travis-ci.org/jameskilton/simple_aws

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs