[ANN] Ruby-GNOME2 1.1.4

Hi,

The Ruby-GNOME2 project released Ruby-GNOME2 1.1.4:
http://ruby-gnome2.sourceforge.jp/hiki.cgi?News_20120721_1

This is a easy to install release!

If you are on Debian, Red Hat, Fedora or Mac OS X, related
native packages are installed automatically. For example,
you type “gem install gtk2” then “sudo apt-get install -V -y
libgtk2.0-dev” is ran automatically on Debian GNU/Linux.

=== Install

% gem install gtk2

=== Changes

==== All

  • Improvements
    • Supported automatic required native packages install.

==== Ruby/GLib2

  • Improvements

    • mkenums: Supported “/* < flags > */” tag.
    • mkenums: Supported two or more upper case characters such as “IO”.
      • Before: GIOStatus -> g_iostatus
      • After: GIOStatus -> g_io_status
    • GIOCondition: Changed to GLib::Boxed object from integer.
    • GLib::Source#attach doesn’t require context.
  • Fixes

    • Fixed wrong type conversion for GIOCondition.

==== Ruby/GIO2

  • Improvements

    • Gio::Socket#create_source: Supported callback.
  • Fixes

    • Fixed return values.
    • Fixed wrong type conversions.

==== Ruby/GTK2

  • Improvements

    • Re-supported GTK+ 2.10.0. [GitHub:115] [Patch by Grant S.]
  • Fixes

    • Fixed a typo in test script.
      [GitHub:109] [Reported by kimura wataru]

==== Ruby/GStreamer

  • Fixes
    • Fixed a test failure with GStreamer 0.10.36.
      [GitHub:111] [Reported by mtasaka]

=== Thanks

  • kimura wataru
  • mtasaka
  • Grant S.

Thanks,

kou

Thanks to everyone who made this possible, especially kou!