[ANN]Rubricks - CMS on Rails


#1

Hi list,

I made an open source CMS powered by Rails, named Rubricks.

I have a web page for Rubricks.
You can download it or view a flash demo there.
Please try them and feed me back, like bug report etc.

Check it out at:
http://rubricks.org/index_en.html

Thanks.

Shouta


#2

Hi Shouta,

I haven’t had a chance to check out anything but the demo yet, but that
looks great!!

Best regards,
Bill

----- Original Message -----
From: “Shouta O.” removed_email_address@domain.invalid
To: removed_email_address@domain.invalid
Sent: 2006-04-17 4:00 AM
Subject: [Rails] [ANN]Rubricks - CMS on Rails


#3

Shouta,

Your site does not seem to be loading.

John


#4

Shouta O. wrote:

Hi list,

I made an open source CMS powered by Rails, named Rubricks.

I have a web page for Rubricks.
You can download it or view a flash demo there.
Please try them and feed me back, like bug report etc.

Check it out at:
http://rubricks.org/index_en.html

Thanks.

Shouta

Hi Shouta, seems interesting, I signed up on the demo page, but my user
can’t seem to do anything… do you have a demo with admin privs so we
can check it out?

the site seems very slick and intuitive (from the flash demo) keep up
the good work!

  • Amr

#5

John H. wrote:

Subject: [Rails] [ANN]Rubricks - CMS on Rails
 > Check it out at:
 > http://rubricks.org/index_en.html

same here… it doesn’t seem to be loading.
hey great demo btw


sig “kind regards” :name => “Arie Kusuma A.”, :callme => “Arie”,
:ym => “riyari3”, :email => “removed_email_address@domain.invalid”,
:blog => “http://ariekusumaatmaja.wordpress.com


#6

Hi,

I have downloaded this and am attempting to get it running. I am
encountering the following problem, though:
ruby script/init_db
./script/…/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:120:in
log': Mysql::Error: #42S02Table 'rubricks.rubricks_configs' doesn't exist: DELETE FROM rubricks_configs (ActiveRecord::StatementInvalid) from ./script/../config/../vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:185:inexecute’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:200:in
delete' from ./script/../config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:283:indelete_existing_fixtures’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/fixtures.rb:256:in
create_fixtures' from ./script/../config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:256:increate_fixtures’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/database_statements.rb:51:in
transaction' from ./script/../config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:255:increate_fixtures’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/base.rb:794:in
silence' from ./script/../config/../vendor/rails/activerecord/lib/active_record/fixtures.rb:248:increate_fixtures’
from script/init_db:36

Is there something I am missing?

Thanks

Shouta O. wrote:

Hi list,

I made an open source CMS powered by Rails, named Rubricks.

I have a web page for Rubricks.
You can download it or view a flash demo there.
Please try them and feed me back, like bug report etc.

Check it out at:
http://rubricks.org/index_en.html

Thanks.

Shouta


#7

John Q. wrote:

Hi,

I have downloaded this and am attempting to get it running. I am
encountering the following problem, though:
ruby script/init_db
./script/…/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:120:in
`log’: Mysql::Error: #42S02Table ‘rubricks.rubricks_configs’ doesn’t
exist: DELETE FROM rubricks_configs (ActiveRecord::StatementInvalid)
from
…snip…

It is complaining that rubricks.rubricks_configs table doesn’t exist.
Did you specify the username/password to the appropriate database in
config/database.yml file? Maybe it expects the rubricks database to be
there when you run the script/init_db ?

-A


#8

I do believe you are correct about it needing the tables to be in place.
I’m not sure how to go about creating them. There is no “migration” to
generate them. Looking around, I can’t seem to find anything that would
generate them. There is an empty schema.rb file, but that seems to be of
no help.

Amr M. wrote:

John Q. wrote:

Hi,

I have downloaded this and am attempting to get it running. I am
encountering the following problem, though:
ruby script/init_db
./script/…/config/…/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract_adapter.rb:120:in
`log’: Mysql::Error: #42S02Table ‘rubricks.rubricks_configs’ doesn’t
exist: DELETE FROM rubricks_configs (ActiveRecord::StatementInvalid)
from
…snip…

It is complaining that rubricks.rubricks_configs table doesn’t exist.
Did you specify the username/password to the appropriate database in
config/database.yml file? Maybe it expects the rubricks database to be
there when you run the script/init_db ?

-A


#9

On 19 Apr 2006, at 12:51, Shouta O. wrote:

Did you run unit or functional tests before executing init_db?
Maybe those test scripts have regenerated blank schema.rb,if you’ve
done so.

Can I suggest that is fixed so that there is a migration in db/
migrate to bootstrap the database in a standard way? And also,
running tests shouldn’t empty schema.rb should it? First thing I do
when I check out a new rails app from somewhere (sometimes before
reading the README!) is:

vi config/database.yml # <- give it a place to play
rake db:migrate

If that fails, I kind of figure the developer is going outside the
way Rails developers behave, which isn’t very Rails-esque, and I
start to get wary of the rest of the developers code.

The demo looks cool though - I think I’ll have a play tonight.

Sorry for my broken English.

I love how people apologise for perfectly good English. I can assure
you, your English is way, way, way better than my Japanese. :slight_smile:


Paul R.


#10

Did you run unit or functional tests before executing init_db?
Maybe those test scripts have regenerated blank schema.rb,if you’ve done
so.

Please get Rubricks again.
And execute init_db before running unit or functional tests.

Sorry for my broken English.
Thanks.

Shouta


#11

Hello Shouta,

when running the database initialization script (BTW; I’d also suggest
to use the standard “rake migrate” command to bootstrap the database),
I found the following error:

– add_index(“rubricks_component_permissions”,
[“rubricks_component_function_id”
], {:name=>“rubricks_component_function_id”})
./script/…/config/…/vendor/rails/activerecord/lib/active_record/connection_ada
pters/abstract_adapter.rb:120:in `log’: SQLite3::SQLException: index
rubricks_co
mponent_function_id already exists: CREATE INDEX
rubricks_component_function_id
ON rubricks_component_permissions (rubricks_component_function_id)
(ActiveRecor
d::StatementInvalid)

Please, see below for the full trace.

Is there something I’m doing wrong? Thank you!


ruby script/init_db -l english
– create_table(“rubricks_block_views”, {:force=>true})
-> 0.1880s
– add_index(“rubricks_block_views”, [“rubricks_menu_item_id”],
{:name=>“rubrick
s_menu_item_id”})
-> 0.0150s
– add_index(“rubricks_block_views”, [“rubricks_block_id”],
{:name=>“rubricks_bl
ock_id”})
-> 0.0160s
– create_table(“rubricks_blocks”, {:force=>true})
-> 0.0160s
– add_index(“rubricks_blocks”, [“rubricks_component_function_id”],
{:name=>“rub
ricks_component_function_id”})
-> 0.0150s
– create_table(“rubricks_component_functions”, {:force=>true})
-> 0.0160s
– add_index(“rubricks_component_functions”, [“rubricks_component_id”],
{:name=>
“rubricks_component_id”})
-> 0.0160s
– create_table(“rubricks_component_permissions”, {:force=>true})
-> 0.0310s
– add_index(“rubricks_component_permissions”,
[“rubricks_component_function_id”
], {:name=>“rubricks_component_function_id”})
./script/…/config/…/vendor/rails/activerecord/lib/active_record/connection_ada
pters/abstract_adapter.rb:120:in log': SQLite3::SQLException: index rubricks_co mponent_function_id already exists: CREATE INDEX rubricks_component_function_id ON rubricks_component_permissions (rubricks_component_function_id) (ActiveRecor d::StatementInvalid) from ./script/../config/../vendor/rails/activerecord/lib/active_record/c onnection_adapters/sqlite_adapter.rb:137:inexecute’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/c
onnection_adapters/sqlite_adapter.rb:335:in catch_schema_changes' from ./script/../config/../vendor/rails/activerecord/lib/active_record/c onnection_adapters/sqlite_adapter.rb:137:inexecute’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/c
onnection_adapters/abstract/schema_statements.rb:196:in add_index' from ./script/../config/../vendor/rails/activerecord/lib/active_record/m igration.rb:272:inmethod_missing’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/m
igration.rb:256:in say_with_time' from c:/ruby/lib/ruby/1.8/benchmark.rb:293:inmeasure’
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/m
igration.rb:256:in say_with_time' from ./script/../config/../vendor/rails/activerecord/lib/active_record/m igration.rb:270:inmethod_missing’
from ./db/schema.rb:41
from
./script/…/config/…/vendor/rails/activerecord/lib/active_record/s
chema.rb:43:in define' from ./db/schema.rb:5 from ./script/../config/../vendor/rails/activerecord/lib/../../activesup port/lib/active_support/dependencies.rb:140:inload’
from script/init_db:3


#12

Hi Shouta,

I tried running the unit tests and functional tests first, but they
failed because the tables didn’t exist.

Shouta O. wrote:

Did you run unit or functional tests before executing init_db?
Maybe those test scripts have regenerated blank schema.rb,if you’ve done
so.

Please get Rubricks again.
And execute init_db before running unit or functional tests.

Sorry for my broken English.
Thanks.

Shouta


#13

Paul R. wrote:

get wary of the rest of the developers code.
OK.
I’ll make changes which can bootstrap the db in an only ‘rake migrate’
to next release.
Thanks, Paul.

Shouta


#14

John Q. wrote:

Hi Shouta,

I tried running the unit tests and functional tests first, but they
failed because the tables didn’t exist.

Sorry for my confusing suggest.
I’ve suggested that don’t run the tests(or rake migration) before run
init_db.

Maybe your schema.rb has broken.(It’s Rubricks’ BUG.)
So,please download and unzip the Rubricks, and try follow:

gem install rubyzip
cd <>
ruby script/init_db -l english
ruby script/init_theme
ruby script/server -e production

http://dev.rubricks.org/wiki/RubricksInstallationGuide

Shouta


#15

First of, there was no logFolder created, nor the xxx.log files,
now I tried to execute
ruby script/init_theme…and I get another bunch of errors like “no such folder” etc

Maybe, this is an archiving tool problem.
Empty folders could be generated with my archiving tool.
Please try to use another tool.

(if you create “/public/stylesheets/themes” folder manually, init_theme
will be done successfully.)

later mySQL had problems to get your shema.rb working, complaining the MySQL syntax, done that manually,

Didn’t you execute ‘rake migrate’ ?
Would you show your broken schema.rb and MySql error trace?

Dont get me wrong, I am sure you did a nice job, but I am also very sure
you have thrown that in public a bit early…all this kind of BUGs is
really annoying, and even if its for free etc…I mean, I was meainly
interested to see HOW you did things…but after this installation pain
I wonder if I really wanna know.

Thank you.I respect your effort.

Rubricks can work well on our PCs…
Didn’t anyone make Rubricks worked well?

Shouta


#16

Shouta O. wrote:

John Q. wrote:

Hi Shouta,

I tried running the unit tests and functional tests first, but they
failed because the tables didn’t exist.

Sorry for my confusing suggest.
I’ve suggested that don’t run the tests(or rake migration) before run
init_db.

Maybe your schema.rb has broken.(It’s Rubricks’ BUG.)
So,please download and unzip the Rubricks, and try follow:

gem install rubyzip
cd <>
ruby script/init_db -l english
ruby script/init_theme
ruby script/server -e production

http://dev.rubricks.org/wiki/RubricksInstallationGuide

Shouta

Hi Shouta,

the flashdemo looks very cool,

unfortunatly I am not able to get it running here local on a
WAM§machine…

First of, there was no logFolder created, nor the xxx.log files, done
that manually…later mySQL had problems to get your shema.rb working,
complaining the MySQL syntax, done that manually, now I tried to execute
ruby script/init_theme…and I get another bunch of errors like “no such
folder” etc
Actually I wont follow this further, even if it looks promising

Dont get me wrong, I am sure you did a nice job, but I am also very sure
you have thrown that in public a bit early…all this kind of BUGs is
really annoying, and even if its for free etc…I mean, I was meainly
interested to see HOW you did things…but after this installation pain
I wonder if I really wanna know.

Actually its a great pity that the nice work you have done raise in such
a bad light with all this installationpain people have and it would be
cool to update either all your installationcode or at least the
installation guide, right now it does not work “out of the box”, at
least not for me and obviously not for others…

Keep on the good work anyway

Regards

matthias oesterle


#17

On 20 Apr 2006 20:42:26 +0900, Shouta O. removed_email_address@domain.invalid
wrote:

Rubricks can work well on our PCs…
Didn’t anyone make Rubricks worked well?

Actually, it worked right out of the box for me, on two different
Windows computers.

However, I couldn’t figure out how to go about using it once it was
installed. From watching the movie, I understood users and the box
model for the pages, but couldn’t figure out how to add real content
to the pages.

-eric


#18

Eric W. wrote:

However, I couldn’t figure out how to go about using it once it was
installed. From watching the movie, I understood users and the box
model for the pages, but couldn’t figure out how to add real content
to the pages.

Sorry, Current version of Rubricks has no real content, only System
Component.
We are making News Component now, and will release it next week.

Our current release plan is follow:

April : News Component
May : RSS Component,Search Block
June : Official Theme2, Calendar Block
July : Todo Component,Forum Component,Dash Board(like mac os x tiger)

Instead of real contents,you can try to install ‘Hello World’ component
now.
http://dev.rubricks.org/wiki/HelloWorldRubricks

P.S.
We’ll give out documents for developing components soon.
We’re dreaming of enriching of components like XOOPS.

Thanks.

Shouta


#19

does this plugin is used by anyone
i need help in installing the component in this plugin


#20

Shouta O. wrote:

Eric W. wrote:

However, I couldn’t figure out how to go about using it once it was
installed. From watching the movie, I understood users and the box
model for the pages, but couldn’t figure out how to add real content
to the pages.

Sorry, Current version of Rubricks has no real content, only System
Component.
We are making News Component now, and will release it next week.

Our current release plan is follow:

April : News Component
May : RSS Component,Search Block
June : Official Theme2, Calendar Block
July : Todo Component,Forum Component,Dash Board(like mac os x tiger)

Instead of real contents,you can try to install ‘Hello World’ component
now.
http://dev.rubricks.org/wiki/HelloWorldRubricks

P.S.
We’ll give out documents for developing components soon.
We’re dreaming of enriching of components like XOOPS.

Thanks.

Shouta

I wonder if there are people here who installed and used Rubricks since
Shouta San sent this announcement.

I am looking for a CMS system which I will be using as the skeleton of
an application I want to develop, and I just had a look at the current
version of Rubricks. I think it looks very promising.

So if anyone have experience / extensions or whatever to share, I’d be
happy to know.

Oren