[ANN] Radiant 0.6.9 "Etch" - Bugfix Release

Looks like it’s time for another release of Radiant:

http://radiantcms.org/download/

Radiant 0.6.9 “Etch” fixes bugs present in the 0.6.8 release. Namely:

  • The inherit attribute on <r:unless_content> now correctly defaults to
    false.
  • Strange stack overflow and class-loading errors no longer occur in
    development mode.
  • The radiant:freeze:edge task will now correctly freeze without the
    TAG,
    BRANCH, or REVISION options.
  • config/environment.rb will be correctly updated when running the
    radiant:update:configs task.
  • You will no longer receive random “authenticity token” errors when
    using the
    cookie session store (the default).
  • script/extension will have the executable bit set on Unix-like
    filesystems.

It also adds one feature:

  • <r:random> will now accept dynamically generated options.

WHAT IS RADIANT CMS?

Radiant is a no-fluff content management system made for designers and
programmers and is ideal for use on small teams. It is similar to
Movable Type or Textpattern, but is much more than a blogging engine.

Radiant features:

  • An elegant user interface
  • The ability to arrange pages in a hierarchy
  • Flexible templating with layouts, snippets, page parts, and a
    custom tagging language (Radius: http://radius.rubyforge.org)
  • A dynamic extension system
  • A simple user management/permissions system
  • Support for Markdown and Textile as well as traditional HTML
    (it’s easy to create other filters)
  • Operates in two modes: dev and production depending on the URL
  • A caching system which expires pages every 5 minutes
  • Built using Ruby on Rails (which means that extending Radiant is
    as easy as any other Rails application)
  • Licensed under the MIT-License
  • And much more…

There’s even a live demo over on the project Web site:

http://radiantcms.org/demo/

WHAT’S NEW IN THIS RELEASE?

  • Make <r:random> accept dynamically generated options. [Jim G., Sean
    Cribbs]
  • Correctly set default ‘inherit’ to false on <r:unless_content> [Mark
    A. Yoon]
  • Correct authenticity token errors when using cookie session store
    [Sean
    Cribbs]
  • Make script/extension executable. [Sean C.]
  • Correct bugs in radiant:freeze:edge task. [Sean C.]
  • Fix strange Page subclass loading errors in development mode. [Sean
    Cribbs]
  • Fix typo in if_content description. [Jim G.]
  • Correct error in radiant:update:configs task. [Sean C.]

INSTALLATION

We’ve worked hard to make it easy to install Radiant. For starters you
can download it with Ruby Gems:

% gem install radiant

Once the Radiant gem is installed you have access to the radiant
command. The radiant command is similar to the rails command (if you
are from the Rails world. It’s how you generate a new Radiant project
for a website. So cd to the directory where you would like your
instance to be installed and type:

% radiant -d [mysql|postgres|sqlite3] .

Next, edit config/database.yml to taste. Then run the rake bootstrap
task:

% rake production db:bootstrap

And start up the test server:

% script/server -e production

Finally, hit the /admin/ URL and you should be off to the races. See the
README file in the release for additional details.

If you are interested in other download options, visit the download
page: http://radiantcms.org/download/.

UPGRADING FROM 0.6.x

  1. Update the Radiant gem:

    % gem update radiant

  2. Change the RADIANT_GEM_VERSION constant in config/environment.rb
    to “0.6.9” or remove it altogether.

  3. Run the update rake task:

    % rake radiant:update

  4. Run migrations:

    % rake db:migrate

  5. Restart the server

UPGRADING FROM 0.5.x

The upgrade process changed significantly from last release, so listen
up! To upgrade an existing installation, BACKUP YOUR DATABASE, update
the gem, and create a new Radiant project using the instructions above.
Then point Radiant to the right database by editing config/database.yml
and execute the following command in your project directory:

% rake db:migrate

If you have problems during the upgrade, please let us know.

CONTRIBUTORS

Radiant wouldn’t be possible without the help of some fine people. The
following people have made contributions to this release:

Mark A. Yoon Sean C. Jim G.

Thanks guys! If you’d like to hop on the development band wagon head on
over to our dev site (http://dev.radiantcms.org/).

SUPPORT

The best place to get support is definitely on the Radiant mailing list.
There’s a crowd of people there who have been hanging around for many
moons now. Newbie questions are welcome! To sign up, go to:

http://radiantcms.org/mailing-list/

The Radiant mailing list is also accessible via Ruby forum:

http://www.ruby-forum.com/forum/21

Enjoy!


Sean C.
for the Radiant CMS Dev Team
http://radiantcms.org

It was a 2-line and very minor change so I pushed out a new gem with the
same version with the fix and moved the tag forward on GitHub. You may
need to remove the 0.6.9 gem in order to update.

Now, the reason this was changed was to generate a unique session key
for each Radiant project. And to keep you up-to-date with any default
settings that were changed in the core. Unfortunately, the ERB
evaluation had to be done manually since we don’t need the complete
generator when we’re simply updating the existing project. I
misunderstood the ERB documentation, resulting in the bug that for some
reason didn’t occur for me locally at first.

Sean

Hi all, I just attempted to upgrade a 0.6.8 install to 0.6.9. The recent
0.6.7 to 0.6.8 went smoothly.

Gem update worked fine.

$ radiant -v
Radiant 0.6.9

Then (in radiant project root) :

$ rake radiant:update --trace
(in /radiant/project/root/)
** Invoke radiant:update (first_time)
** Invoke radiant:update:scripts (first_time)
** Execute radiant:update:scripts
** Invoke radiant:update:javascripts (first_time)
** Execute radiant:update:javascripts
** Invoke radiant:update:configs (first_time)
** Execute radiant:update:configs
rake aborted!
undefined local variable or method app_name' for main:Object (erb):42 /usr/lib64/ruby/gems/1.8/gems/radiant-0.6.9/lib/tasks/framework.rake:107:inopen’
/usr/lib64/ruby/gems/1.8/gems/radiant-0.6.9/lib/tasks/framework.rake:106
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:546:in call' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:546:inexecute’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:541:in each' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:541:inexecute’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:508:in
invoke_with_call_chain' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:insynchronize’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in
invoke_with_call_chain' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:518:ininvoke_prerequisites’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in each' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:insend’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1183:in each' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:515:ininvoke_prerequisites’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:507:in
invoke_with_call_chain' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:insynchronize’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:501:in
invoke_with_call_chain' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:494:ininvoke’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1931:in
invoke_task' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:intop_level’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:in each' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1909:intop_level’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:in
standard_exception_handling' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1903:intop_level’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1881:in run' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1948:instandard_exception_handling’
/usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/lib/rake.rb:1878:in run' /usr/lib64/ruby/gems/1.8/gems/rake-0.8.1/bin/rake:31 /usr/bin/rake:19:inload’
/usr/bin/rake:19

Not sure what went wrong…

Worked like a charm.
Thanks Sean.

In case it helps anyone else:
#gem uninstall radiant
Select gem to uninstall:

  1. radiant-0.6.7
  2. radiant-0.6.8
  3. radiant-0.6.9
  4. All versions

3
#gem update radiant
$rake radiant:update
$rake db:migrate

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs