[ANN] JRuby Debugger 0.10.3


#1

Hi all,

I’ve just released (j)ruby-debug-base-0.10.3. This release does not
contain anything new, just is compatible with recently ruby-debug(-cli)
0.10.3, so you should get bunch of new feature brought by ruby-debug
team.

And sure, mainly it work again with JRuby 1.1.5 (which was not the case
with (j)ruby-debug-base-0.10.2 (was the main reason for soonish release)

ruby-debug 0.10.3 also contains patch which makes it possible to release
minor releases like ruby-debug-base-0.10.3.x, so the situation with
non-working (j)ruby-debug-base 0.10.2 vs JRuby 1.1.5 should not be big
issue anymore.

If you encounter any bugs…

Feedback appreciated:
http://rubyforge.org/tracker/?group_id=3085

Installation:
http://debug-commons.rubyforge.org/#jruby-debug

Download:
http://rubyforge.org/frs/?group_id=3085

Sources:
https://rubyforge.org/scm/?group_id=3085

Thanks,

m.


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#2

Hi Martin

I can’t get the fast debugger to woak with Netbeans 6.5 RC2 and Jruby
1.1.5 seems like netbeans expects a ruby debug-ide with version 0.3.x
and when i try with ruby-debug-ide-0.3.1 expects jruby-debugger 0.10.2
when i try to debug

Netbeans error message is “ruby-debug-ide in version matching 0.3.*
pattern is not installed”

Martin K. wrote:

Hi all,

I’ve just released (j)ruby-debug-base-0.10.3. This release does not
contain anything new, just is compatible with recently ruby-debug(-cli)
0.10.3, so you should get bunch of new feature brought by ruby-debug
team.

And sure, mainly it work again with JRuby 1.1.5 (which was not the case
with (j)ruby-debug-base-0.10.2 (was the main reason for soonish release)


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#3

I noticed that NB6.5 final was released so i re-tried but got the same
error

/M

Hi Martin

I can’t get the fast debugger to woak with Netbeans 6.5 RC2 and Jruby
1.1.5 seems like netbeans expects a ruby debug-ide with version 0.3.x
and when i try with ruby-debug-ide-0.3.1 expects jruby-debugger 0.10.2
when i try to debug

Netbeans error message is “ruby-debug-ide in version matching 0.3.*
pattern is not installed”


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#4

Mikael R. wrote:

Hi Martin

I can’t get the fast debugger to woak with Netbeans 6.5 RC2 and Jruby
1.1.5 seems like netbeans expects a ruby debug-ide with version 0.3.x
and when i try with ruby-debug-ide-0.3.1 expects jruby-debugger 0.10.2
when i try to debug

Netbeans error message is “ruby-debug-ide in version matching 0.3.*
pattern is not installed”

Hi Mikael,

NetBeans 6.5 final depends on ruby-debug-ide 0.3.x which depended on
ruby-debug-base 0.10.2 which does not work with JRuby 1.1.5.

Protocol in ruby-debug-ide 0.3.x differs from ruby-debug-ide 0.4.x[1],
so NetBeans 6.5 has a check for the appropriate version, since they can
communicate only with 0.3.x protocol.

I’ve just released 0.3.2 with dependency on ruby-debug-base 0.10.3.

https://rubyforge.org/frs/?group_id=3085

You might need to wait until the gem is propagated to rubyforge.org.

Or you might grab 7.0 dev build which works with ruby-debug-ide 0.4.x
and contains bunch of new features (since 6.5)[2].

m.

[1] http://debug-commons.rubyforge.org/protocol-spec.html#SEC20
[2] http://wiki.netbeans.org/RubyRecentChanges


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

#5

Martin K. wrote:

I’ve just released 0.3.2 with dependency on ruby-debug-base 0.10.3.

Thanks a bunch Martin. I just download and installed it. It works like a
charm :slight_smile:

/Mikael


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email