[ANN] activerecord-jdbc-adapter 0.9.4 released

Hi all,

I pushed out a (somewhat) rushed 0.9.4 release this afternoon which
should resolve the issues you’ve been seeing with Rails 3 beta 2.
Please give it a try (gem install activerecord-jdbc-adapter) and let
me know how Rails 3 is working for you.

Two things of note:

  1. With 0.9.3 and Rails 3.0 beta (first beta) hsqldb, h2, and derby
    drivers didn’t work at all. Those drivers (along with most drivers)
    should be working fine with this release combined with 3.0 beta2.
    2 We no longer need the “jdbc” generator with Rails 3 and Bundler.
    Given the following in your Gemfile:

gem “activerecord-jdbc-adapter”
gem “jdbc-mysql”, :require => “false” # replace with the adapter you
use as needed

This will automatically inject the adapter code using a Railtie.

Those of you filing other recent ar-jdbc issues not related to Rails
3, thanks and please be patient. I’ll try to make another pass and see
if we can get another release out soon that fixes more of the bugs in
the backlog. Of course patches are appreciated and greatly increase
the chances of the bug getting resolved in the next release.

Cheers,
/Nick


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

Hi Nick,

I tried to make Rails3 Beta2 and JRuby working, but no success yet.
First when I try

gem “activerecord-jdbc-adapter”
gem “jdbc-mysql”, :require => “false”

as you suggested I get


require’: no such file to load – false (LoadError)

So I changed the second line to
gem “jdbc-mysql”, :require => false

rails s then produces:

Please install the jdbc-sqlite3 adapter: gem install activerecord-jdbc-sqlite3-adapter (no such file to load –
active_record/connection_adapters/jdbc-sqlite3_adapter) (RuntimeError)

So I installed “activerecord-jdbcsqlite3-adapter” (NOT
activerecord-jdbc-sqlite3-adapter as suggested from the output, since it
doesn’t exist and I found some threads about a false naming of the gem).
However, I still get the error, every time I want to start rails. I am
pretty much stuck here.
Here is my gem list:

abstract (1.0.0)
acl9 (0.12.0)
actionmailer (3.0.0.beta2)
actionpack (3.0.0.beta2)
activemodel (3.0.0.beta2)
activerecord (3.0.0.beta2)
activerecord-jdbc-adapter (0.9.4)
activerecord-jdbcsqlite3-adapter (0.9.4)
activeresource (3.0.0.beta2)
activesupport (3.0.0.beta2)
arel (0.3.3)
authlogic-oid (1.0.4)
builder (2.1.2)
bundler (0.9.18)
erubis (2.6.5)
i18n (0.3.6)
jdbc-sqlite3 (3.6.3.054)
jruby-openssl (0.6)
mail (2.2.0, 2.1.5.3)
memcache-client (1.8.2)
mime-types (1.16)
polyglot (0.3.1)
rack (1.1.0)
rack-mount (0.6.1)
rack-test (0.5.3)
rails (3.0.0.beta2)
railties (3.0.0.beta2)
rake (0.8.7)
text-format (1.0.0)
text-hyphen (1.0.0)
thor (0.13.4)
treetop (1.4.5)
tzinfo (0.3.19)

I use JRuby Head with RVM on a Mac.

Ok, I got it running. It wasn’t a gem problem, instead I copied an old
database.yml with “jdbc-sqlite3” in it.
Everything looks good with JRuby/Rails 3 so far.

On Mon, Apr 12, 2010 at 1:57 AM, Helmut J. [email protected]
wrote:


require’: no such file to load – false (LoadError)

Whoops! I specified false as a string. Sorry about that!

/Nick


To unsubscribe from this list, please visit:

http://xircles.codehaus.org/manage_email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs