An functional notion for signal processing block connections

Here I have a prototype of functional style notation for GNU radio
signal
processing block connections. I wonder if it would be easier to use than
the original
self.connect(…), self.connect(…) - notation.
What do you think about this?

http://kks.cabal.fi/FreqShift#A_rude_frequency_shifter_for_mic_audio_by_using_syntax.py_for_connections

And another thing…
I guess you can imagine and implement some simple rules to optimize the
signal processing flow before it is actually done by using GNU radio
signal
processing blocks.
At it’s simplest form it would mean for example something like:

self.connect(source, gr.add_const_xx, gr.add_const_xx, sink)
–>
self.connect(source, gr.add_const_xx, sink)

Has anyone done something like this for GNU radio already?

  • Pauli Rikula

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs