Amrita 1.0.2 fails its unit tests


#1

Hi folks,

Amrita 1.0.2 fails 5 of its unit tests when I run them. After
downloading a fresh copy of Amrita, uncompressing it and uploading it to
an Ubuntu 5.10 box, I received the test failures below.

Any idea why I receive these errors? It would seem this package should
pass its test out of the box.

Thanks,
Ben

  1. Error:
    TestTemplate#test_template_file2:
    NameError: uninitialized constant REXML::File
    ./lib/amrita/xml.rb:101:in parse_file' ./lib/amrita/template.rb:274:inload_template’
    ./lib/amrita/template.rb:208:in setup_template' ./lib/amrita/template.rb:115:inexpand’
    test/testtemplate.rb:120:in test_template_file2' /usr/lib/ruby/1.8/runit/testcase.rb:42:inrun’
    /usr/lib/ruby/1.8/runit/testsuite.rb:23:in run' /usr/lib/ruby/1.8/runit/testsuite.rb:23:inrun’

  2. Failure:
    TestFormat2#test_expand_by_proc2
    [test/testformat2.rb:189:in test_expand_by_proc2' /usr/lib/ruby/1.8/runit/testcase.rb:42:inrun’
    /usr/lib/ruby/1.8/runit/testsuite.rb:23:in run' /usr/lib/ruby/1.8/runit/testsuite.rb:23:inrun’]:
    <"\n<li color=“blue”>0

  3. \n<li color=“red”>1\n<li
    color=“blue”>2\n<li color=“red”>3\n<li
    color=“blue”>4\n<li color=“red”>5"> expected but was
    <"<li color=“blue”>0<li color=“red”>1<li
    color=“blue”>2<li color=“red”>3<li
    color=“blue”>4<li color=“red”>5">.
  4. Failure:
    TestParts#test_parts_withcache
    [test/testparts.rb:156:in test_parts_withcache' /usr/lib/ruby/1.8/runit/testcase.rb:42:inrun’
    /usr/lib/ruby/1.8/runit/testsuite.rb:23:in run' /usr/lib/ruby/1.8/runit/testsuite.rb:23:inrun’]:
    <“

    xxx

    ”> expected but was
    <"

    #<TestParts::EMText:0xb7b537bc>

    ">.
  5. Failure:
    TestXML#test_listener
    [test/testxml.rb:42:in test_listener' /usr/lib/ruby/1.8/runit/testcase.rb:42:inrun’
    /usr/lib/ruby/1.8/runit/testsuite.rb:23:in run' /usr/lib/ruby/1.8/runit/testsuite.rb:23:inrun’]:
    <"<?xml version=\"1.0\"?><html
    xmlns=“http://www.w3.org/1999/xhtml”> xhtml
    sample <h1 id=“title”>title <p
    id=“body”>body text


    “> expected but was
    <”<?xml version=\"1.0\"?><html
    xmlns=“http://www.w3.org/1999/xhtml”> xhtml
    sample <h1 id=“title”>title <p
    id=“body”>body text
    ">.
  6. Error:
    TestXML#test_amx1:
    NameError: uninitialized constant REXML::File
    ./lib/amrita/amx.rb:59:in []' test/testxml.rb:103:intest_amx1’
    /usr/lib/ruby/1.8/runit/testcase.rb:42:in run' /usr/lib/ruby/1.8/runit/testsuite.rb:23:inrun’
    /usr/lib/ruby/1.8/runit/testsuite.rb:23:in `run’

140 tests, 881 assertions, 3 failures, 2 errors: