All rails scripts running slow -- require_frameworks() probl

I’m using InstantRails to build my rails app. Anytime i try to run a
rails script (the two i usually run are ruby script/server webrick and
ruby script/runner 'Mailer.check_mail' (an ActionMailer to check a
GMail account over IMAP and retrieve messages). I have profiled both of
these applications with Ruby Performance Validator, and they are both
spending like 98% of the time at require_frameworks(). I can see that
as being acceptable for webrick, but why would the mailer script be
running so slow, especially after I have webrick (and the associated
frameworks) loaded and running?

I have tried messing around with setting RUBYOPT=rubygems, but that
doesn’t seem to help.

I am on a windows box running Ruby 1.8.6, Rails 2.0.2. Any help would
be appreciated!

On Apr 14, 10:22 pm, Orange 73 [email protected]
wrote:

I’m using InstantRails to build my rails app. Anytime i try to run a
rails script (the two i usually run are ruby script/server webrick and
ruby script/runner 'Mailer.check_mail' (an ActionMailer to check a
GMail account over IMAP and retrieve messages). I have profiled both of
these applications with Ruby Performance Validator, and they are both
spending like 98% of the time at require_frameworks(). I can see that
as being acceptable for webrick, but why would the mailer script be
running so slow, especially after I have webrick (and the associated
frameworks) loaded and running?

script/runner loads the entire framework (it’s kind of the point of
it) so it’s never going to be lightening fast. If you’re going to be
running the script often you may be better off with a long running
process rather than thrashing around reloading rails every 30 seconds.

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs