All domains picking same content of one site?

Hii,
I am running several sites at dedicated server. Earlier i was using
apache only, but now i’ve change it to nginx and now i’m using nginx
with apache.

But after installing inginx, my one site is working properly, but rest
all five sites picking the same data of one site.

I’ve configured apache to port 8080 and Nginx to port 80.

Please Suggest what needs to be done.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,58161,58161#msg-58161

Hi

How have you configured virtual servers in nginx? You have to configure
each domain to go to its content, if you haven’t it wouldn’t work. Could
you post the part of your config dealing with this?

You say you’re using both apache and nginx. But do they work together or
you just want to have them side by side in order to compare them? In
other workds, does nginx act as a proxy to apache or it works on its
own?

Regards

El 28/02/2010, a las 06:01, sam77am
escribió:


nginx mailing list
[email protected]
http://nginx.org/mailman/listinfo/nginx


Vicente A. [email protected] | http://www.bisente.com

Hi Vicente,

Thanks for your revert…

Below is the config details.

nginx.conf -

#######################################################################

This is the main Nginx configuration file.

More information about the configuration options is available on

* the English wiki - http://wiki.codemongers.com/Main

* the Russian documentation - http://sysoev.ru/nginx/

#######################################################################

#----------------------------------------------------------------------

Main Module - directives that cover basic functionality

http://wiki.codemongers.com/NginxMainModule

#----------------------------------------------------------------------

user nginx;
worker_processes 4;

error_log /var/log/nginx/error.log;
#error_log /var/log/nginx/error.log notice;
#error_log /var/log/nginx/error.log info;

pid /var/run/nginx.pid;

#----------------------------------------------------------------------

Events Module

http://wiki.codemongers.com/NginxEventsModule

#----------------------------------------------------------------------

events {
worker_connections 1024;
}

#----------------------------------------------------------------------

HTTP Core Module

http://wiki.codemongers.com/NginxHttpCoreModule

#----------------------------------------------------------------------

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;
log_format main '$remote_addr - $remote_user [$time_local] $request ’
'"$status" $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" “$http_x_forwarded_for”’;
access_log /var/log/nginx/access.log main;
sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
gzip on;

# Load config files from the /etc/nginx/conf.d directory

include /etc/nginx/conf.d/*.conf;

The default server

server {
listen 80;
server_name YOURSERVERNAME;
#charset koi8-r;
#access_log logs/host.access.log main;
#Main location
location / {
proxy_pass http://myip:8080/;
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_connect_timeout 90;
proxy_send_timeout 90;
proxy_read_timeout 90;
client_max_body_size 10m;
client_body_buffer_size 128k;
proxy_buffer_size 4k;
proxy_buffers 4 32k;
proxy_busy_buffers_size 64k;
root /usr/share/nginx/html;
index index.html index.htm index.php;
}

    error_page  404              /404.html;
    location = /404.html {
        root   /usr/share/nginx/html;
    }

    # redirect server error pages to the static page /50x.html
    #
    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   /usr/share/nginx/html;
    }

    # proxy the PHP scripts to Apache listening on myip:80
    #
    #location ~ \.php$ {
    #    proxy_pass   http://myip;
    #}

    # pass the PHP scripts to FastCGI server listening on myip:9000
    #
    #location ~ \.php$ {
    #    root           html;
    #    fastcgi_pass   127.0.0.1:9000;
    #    fastcgi_index  index.php;
    #    fastcgi_param  SCRIPT_FILENAME 

/scripts$fastcgi_script_name;
# include fastcgi_params;
#}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~* 

^.+.(jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|txt|tar|wav|bmp|rtf|js)$
{root /var/www;}
}
}

I am using nginx as proxy…please suggest what changes needs to be
done.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,58161,58223#msg-58223

Hi Vicente,

Thanks for your revert…

Below is the config details.

nginx.conf -

#######################################################################

This is the main Nginx configuration file.

More information about the configuration options is available on

* the English wiki - http://wiki.codemongers.com/Main

* the Russian documentation - http://sysoev.ru/nginx/

#######################################################################

#----------------------------------------------------------------------

Main Module - directives that cover basic functionality

http://wiki.codemongers.com/NginxMainModule

#----------------------------------------------------------------------

user nginx;
worker_processes 4;

error_log /var/log/nginx/error.log;
#error_log /var/log/nginx/error.log notice;
#error_log /var/log/nginx/error.log info;

pid /var/run/nginx.pid;

#----------------------------------------------------------------------

Events Module

http://wiki.codemongers.com/NginxEventsModule

#----------------------------------------------------------------------

events {
worker_connections 1024;
}

#----------------------------------------------------------------------

HTTP Core Module

http://wiki.codemongers.com/NginxHttpCoreModule

#----------------------------------------------------------------------

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;
log_format main '$remote_addr - $remote_user [$time_local] $request ’
'"$status" $body_bytes_sent “$http_referer” ’
‘"$http_user_agent" “$http_x_forwarded_for”’;
access_log /var/log/nginx/access.log main;
sendfile on;
tcp_nopush on;
tcp_nodelay on;
keepalive_timeout 65;
gzip on;

# Load config files from the /etc/nginx/conf.d directory

include /etc/nginx/conf.d/*.conf;

The default server

server {
listen 80;
server_name YOURSERVERNAME;
#charset koi8-r;
#access_log logs/host.access.log main;
#Main location
location / {
proxy_pass http://myip:8080/;
proxy_redirect off;
proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_connect_timeout 90;
proxy_send_timeout 90;
proxy_read_timeout 90;
client_max_body_size 10m;
client_body_buffer_size 128k;
proxy_buffer_size 4k;
proxy_buffers 4 32k;
proxy_busy_buffers_size 64k;
root /usr/share/nginx/html;
index index.html index.htm index.php;
}

    error_page  404              /404.html;
    location = /404.html {
        root   /usr/share/nginx/html;
    }

    # redirect server error pages to the static page /50x.html
    #
    error_page   500 502 503 504  /50x.html;
    location = /50x.html {
        root   /usr/share/nginx/html;
    }

    # proxy the PHP scripts to Apache listening on myip:80
    #
    #location ~ \.php$ {
    #    proxy_pass   http://myip;
    #}

    # pass the PHP scripts to FastCGI server listening on myip:9000
    #
    #location ~ \.php$ {
    #    root           html;
    #    fastcgi_pass   127.0.0.1:9000;
    #    fastcgi_index  index.php;
    #    fastcgi_param  SCRIPT_FILENAME 

/scripts$fastcgi_script_name;
# include fastcgi_params;
#}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~* 

^.+.(jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|exe|pdf|ppt|txt|tar|wav|bmp|rtf|js)$
{root /var/www;}
}
}

I am using nginx as proxy…please suggest what changes needs to be
done.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,58161,58220#msg-58220

On Sun, Feb 28, 2010 at 7:54 PM, sam77am [email protected] wrote:

I am using nginx as proxy…please suggest what changes needs to be done.

unless there’s another server block in /etc/nginx/conf.d/*.conf, then
surely it’ll show same page for any domain.


O< ascii ribbon campaign - stop html mail - www.asciiribbon.org

Hi

Below is the config details

Doesn’t look bad to me. Anyway:

server {
listen 80;
server_name YOURSERVERNAME;

You need real server names here, I guess you know that and you’re just
hiding your server name, just like below with “myip”.

The whole server block is like a block in Apache, and
server_name is the list of ServerName and ServerAlias for that vhost.
You can either replicate the server section for each vhost with
different server names and different options, or use a generic config
with server_name wildcards like “server_name _;” as per:

http://wiki.nginx.org/NginxHttpCoreModule#server_name

If you only have one name on server_name, I guess nginx would only serve
that domain.

location / {
proxy_pass http://myip:8080/;
proxy_redirect off;
proxy_set_header Host $host;

This looks ok, you’re correctly setting the Host header so that nginx
passes it to Apache.

I assume you’ve tested Apache and it’s working OK for every domain. One
thing you can test is sniffing some traffic between nginx and Apache
with tcpdump and make sure nginx is setting the correct Host header and
Apache is returning the proper content. Anyway that part of the config
looks ok.

Hope that helps.

Regards


Vicente A. [email protected] | http://www.bisente.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs