Alias_method error with 1.2.x?

I’m running edge (6340) and installed a brand new copy of the engines
plugin from svn. I start mongrel, and it immediately fails, complaining
about alias_method not being found.

Known issue?


Because of the changes that Koz made to the plugin initialization
process, the engines plugin won’t work with edge rails at the moment.
See the Rails weblog for details; I’ve yet to decide the best way to
implement a fix for this.

  • James

What is the most current tag Engines works with?



I’m back-patching some old code. What’s the last version of Rails and
Engines that supports the login and user engines? I’d just as soon
not rewrite that code :slight_smile:



Engines 1.1.4, Rails 1.1.6 should sort you.

The current engines release branch (1.2.x) works with the Rails 1.2.x
branch, so at the moment it’s Rails 1.2.2.



Hello, I am trying to get UserEngine and LoginEngine working again
after I accidentally ended up with a too-new rails.

I took Rails back to 1.1.6 and Engines back to 1.1.4 as discussed
below in the original thread. I have the latest/last login_engine and
user_engine installed. Ruby is
1.8.5. When I try to launch my app, I get the error below. Any clue
what I am doing wrong?

(Possibility: I’m not certain I installed engines 1.1.4 correctly – I
did “ruby
script/plugin install” then cd-ed to
vendor/plugin and changed the name of rel_1.1.4 to “engines”.)

ruby script/server
=> Booting WEBrick…
./script/…/config/…/config/environment.rb:82: undefined method
check_system_roles' for UserEngine:Module (NoMethodError) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
require' from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:147:inrequire’
gem_original_require' from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:inrequire’
require' from /usr/local/lib/ruby/gems/1.8/gems/rails-1.1.6/lib/commands/server.rb:30 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from script/server:3

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs