AJAX works in Safari, broken in Firefox

I’ve been working on an AJAX search, very similar to the Flickr one
in the screencast linked from the main rails page. I’ve been doing my
testing in Safari, where everything has worked fine, only to now
discover the results of the search action seem disinclined to load in
Firefox. I can enter a URL to return the HTML fragment that’s
supposed to be dropped into the page:


The HTML fragment displays correctly in Safari, but when I try it in
Firefox (1.0.4 or 1.5), the page acts like it’s loading for a moment,
but then stops without displaying any content. I tried it with “curl”
on the command line as well, and it worked fine (once I stripped off
the login authentication stuff.)

This has me pretty well flummoxed. Has anybody experienced anything
similar, or have any ideas on where to further investigate?

Thanks in advance,

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs