Ajax, buttons, and firefox

I created a button_to_remote function that I use to call :toggle_blind

visual_effect :toggle_blind, ‘div_id’

It works great on Safari, Opera, IE, but in firefox the button does
nothing. Is there a problem with firefox. I can’t seem to find much
online about this issue.


Amos K.
Ramped Media
USPS
Programmer/Analyst
St. Louis, MO
Looking for something to do? Visit ImThere.com

Hi Amos,

Amos K. wrote:

It works great on Safari, Opera, IE, but in firefox the button does
nothing. Is there a problem with firefox. I can’t seem to find much
online about this issue.

First thing I always to with an Ajax problem now, especially in Firefox
because it doesn’t tolerate even small errors sometimes, is to run the
page
source through the w3c XHTML validator. If you’ve already done that and
it
validates, you’ll need to post some code for us to help.

Best regards,
Bill

I figured it out. When it prints the function to the page it puts it
in " " then when I put the form name in " " it changes them to
“form_name” if I put it in ’ ’ it works. I guess the others
just read it correctly.

On 5/11/07, Bill W. [email protected] wrote:

because it doesn’t tolerate even small errors sometimes, is to run the page
source through the w3c XHTML validator. If you’ve already done that and it
validates, you’ll need to post some code for us to help.

Best regards,
Bill


Amos K.
Ramped Media
USPS
Programmer/Analyst
St. Louis, MO
Looking for something to do? Visit ImThere.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs