Aggiornamento in produzione rails 2.1

Ciao a tutti,
aggiornando a rails 2.1 sul mio laptop ho riscontrato qualche problema
con
una doppia inizializzazione di activerecord

usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:142:in `activate’: can’t
activate activerecord (= 2.0.2, runtime), already activated
activerecord-2.1.0 (Gem::Exception)

ho risolto disinstallando la vecchia gemma

il problema è che mi sta capitando la stessa cosa in produzione… qui non
posso disinstallare le vecchie gemme per ovvi motivi…

avete affrontato pure voi questo problema?

ciao e grazie!


Piero B.
My Blog: cookedapple.net
LinkedIn: http://www.linkedin.com/in/pbozzolo
Linux User #403396

Please consider the environment before you print this email

Piero B. wrote:

usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:142:in `activate’: can’t
activate activerecord (= 2.0.2, runtime), already activated
activerecord-2.1.0 (Gem::Exception)

In environment.rb hai specificato la versione di rails da usare?

Si, tutto ok, alla fine ho risolto, con un gem cleanup che mia ha
mantentuto
ror 2.1 e poi ho rinstallato ror 2.0.2

Grazie!

On Fri, Jul 4, 2008 at 11:08 PM, S2 akira [email protected] wrote:

[email protected]
http://lists.ruby-it.org/mailman/listinfo/ml


Piero B.
My Blog: cookedapple.net
LinkedIn: http://www.linkedin.com/in/pbozzolo
Linux User #403396

Please consider the environment before you print this email

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs