Adresse http://0.0.0.0:3000 nicht erreichbar


#1

Hallo,

mein Problem besteht darin, daß das Setup einwandfrei verlaufen ist, ich
aber mit der Adresse http://0.0.0.0:3000 nichts erreiche. Die Firewall
hab ich nunmehr deaktiviert. Was kann ich tun?

Für eine umgehende Antwort wäre ich sehr dankbar, da ich unter hohem
Zeitdruck stehe.

Für eure Mühe bedanke ich mich im Vorraus.

Herzlichen Gruß

toltec

:~/webvz.2.0# ruby script/server
=> Booting WEBrick…
=> Rails 2.1.0 application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-10-13 09:40:08] INFO WEBrick 1.3.1
[2008-10-13 09:40:08] INFO ruby 1.8.6 (2008-08-08) [x86_64-linux]
[2008-10-13 09:40:08] INFO WEBrick::HTTPServer#start: pid=3170
port=3000


#2

Am 13.10.2008 um 09:59 schrieb Ralph Woermke:

mein Problem besteht darin, daß das Setup einwandfrei verlaufen ist,
ich
aber mit der Adresse http://0.0.0.0:3000 nichts erreiche. Die Firewall
hab ich nunmehr deaktiviert. Was kann ich tun?

zu erstmal ./script/server
und es geht auch http://127.0.0.1:3000 oder http://localhost:3000

ciao, tom


Thomas R. “TomK32” Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32


#3

Thomas R. Koll wrote:

Am 13.10.2008 um 09:59 schrieb Ralph Woermke:

mein Problem besteht darin, da� das Setup einwandfrei verlaufen ist,
ich
aber mit der Adresse http://0.0.0.0:3000 nichts erreiche. Die Firewall
hab ich nunmehr deaktiviert. Was kann ich tun?

zu erstmal ./script/server
und es geht auch http://127.0.0.1:3000 oder http://localhost:3000

ciao, tom


Thomas R. “TomK32” Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32

Danke für die sehr schnelle Antwort.

Leider geht immer noch nichts:

Firefox kann keine Verbindung zu dem Server unter 127.0.0.1:3000
aufbauen.

Firefox kann keine Verbindung zu dem Server unter 0.0.0.0:3000 aufbauen.

Firefox kann keine Verbindung zu dem Server unter localhost:3000
aufbauen.

www:~# cd /root/webvz.2.0
www:~/webvz.2.0# ruby script/server
=> Booting WEBrick…
=> Rails 2.1.0 application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-10-13 09:40:08] INFO WEBrick 1.3.1
[2008-10-13 09:40:08] INFO ruby 1.8.6 (2008-08-08) [x86_64-linux]
[2008-10-13 09:40:08] INFO WEBrick::HTTPServer#start: pid=3170
port=3000
exit
^C[2008-10-13 10:06:11] INFO going to shutdown …
[2008-10-13 10:06:11] INFO WEBrick::HTTPServer#start done.
www:~/webvz.2.0# ruby ./script/server
=> Booting WEBrick…
=> Rails 2.1.0 application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-10-13 10:06:44] INFO WEBrick 1.3.1
[2008-10-13 10:06:44] INFO ruby 1.8.6 (2008-08-08) [x86_64-linux]
[2008-10-13 10:06:44] INFO WEBrick::HTTPServer#start: pid=3192
port=3000
^C[2008-10-13 10:07:40] INFO going to shutdown …
[2008-10-13 10:07:40] INFO WEBrick::HTTPServer#start done.
www:~/webvz.2.0# ./script/server
=> Booting WEBrick…
=> Rails 2.1.0 application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-10-13 10:08:03] INFO WEBrick 1.3.1
[2008-10-13 10:08:03] INFO ruby 1.8.6 (2008-08-08) [x86_64-linux]
[2008-10-13 10:08:03] INFO WEBrick::HTTPServer#start: pid=3194
port=3000

Any idea?

Gruß

Ralph


#4

Hallo Ralph,

On Mon, Oct 13, 2008 at 10:13:07AM +0200, Ralph Woermke wrote:

Leider geht immer noch nichts:

Firefox kann keine Verbindung zu dem Server unter 127.0.0.1:3000
aufbauen.

Firefox kann keine Verbindung zu dem Server unter 0.0.0.0:3000 aufbauen.

Firefox kann keine Verbindung zu dem Server unter localhost:3000
aufbauen.

Möglicherweise hast du eienn Proxy in Firefox aktiv, den du für
127.0.0.1
deaktivieren müsstest.

Hast du schon mal einen anderen Browser oder ein “telnet 127.0.0.1 3000”
probiert?

Jan


Jan T. Mail: removed_email_address@domain.invalid
ETES GmbH Fon : +49 (7 11) 48 90 83 - 17
Gablenberger Hauptstrasse 32 Fax : +49 (7 11) 48 90 83 - 50
D-70186 Stuttgart Web : http://www.etes.de/

Registergericht: Amtsgericht Stuttgart HRB 721182
Geschäftsführende Gesellschafter: Markus Espenhain und Jan T.
Sitz der Gesellschaft: Stuttgart
USt.-Id.Nr.: DE814767446


#5

Ralph Woermke wrote:

Jan T. wrote:

Hallo Ralph,

On Mon, Oct 13, 2008 at 10:13:07AM +0200, Ralph Woermke wrote:

Leider geht immer noch nichts:

Firefox kann keine Verbindung zu dem Server unter 127.0.0.1:3000
aufbauen.

Firefox kann keine Verbindung zu dem Server unter 0.0.0.0:3000 aufbauen.

Firefox kann keine Verbindung zu dem Server unter localhost:3000
aufbauen.

Möglicherweise hast du eienn Proxy in Firefox aktiv, den du für
127.0.0.1
deaktivieren müsstest.

Hast du schon mal einen anderen Browser oder ein “telnet 127.0.0.1 3000”
probiert?

Jan
ww:~/webvz.2.0# telnet 127.0.0.1 3000
Trying 127.0.0.1…
Connected to 127.0.0.1.
Escape character is ‘^]’.
ehlo localhost
HTTP/1.1 400 Bad Request
Connection: close
Date: Mon, 13 Oct 2008 08:46:04 GMT
Content-Type: text/html
Server: WEBrick/1.3.1 (Ruby/1.8.6/2008-08-08)
Content-Length: 290

Bad Request

Bad Request

bad URI `localhost'.
WEBrick/1.3.1 (Ruby/1.8.6/2008-08-08) at www.morgen-licht.de:3000 Connection closed by foreign host. www:~/webvz.2.0#

So weit, so gut.

Was könnte ich jetzt konkret tun?

Gruß

Ralph


Jan T. Mail: removed_email_address@domain.invalid
ETES GmbH Fon : +49 (7 11) 48 90 83 - 17
Gablenberger Hauptstrasse 32 Fax : +49 (7 11) 48 90 83 - 50
D-70186 Stuttgart Web : http://www.etes.de/

Registergericht: Amtsgericht Stuttgart HRB 721182
Gesch�ftsf�hrende Gesellschafter: Markus Espenhain und Jan T.
Sitz der Gesellschaft: Stuttgart
USt.-Id.Nr.: DE814767446

HabeNeustart gemacht und der Fehler ist nun ersichtlich.

www:~# cd /root/webvz.2.0
www:~/webvz.2.0# ruby .script/server
ruby: No such file or directory – .script/server (LoadError)
www:~/webvz.2.0# ruby ./script/server
=> Booting WEBrick…
=> Rails 2.1.0 application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-10-13 10:37:08] INFO WEBrick 1.3.1
[2008-10-13 10:37:08] INFO ruby 1.8.6 (2008-08-08) [x86_64-linux]
[2008-10-13 10:37:08] WARN TCPServer Error: Address already in use -
bind(2)
/usr/local/lib/ruby/1.8/webrick/utils.rb:73:in initialize': Address already in use - bind(2) (Errno::EADDRINUSE) from /usr/local/lib/ruby/1.8/webrick/utils.rb:73:innew’
from /usr/local/lib/ruby/1.8/webrick/utils.rb:73:in
create_listeners' from /usr/local/lib/ruby/1.8/webrick/utils.rb:70:ineach’
from /usr/local/lib/ruby/1.8/webrick/utils.rb:70:in
create_listeners' from /usr/local/lib/ruby/1.8/webrick/server.rb:75:inlisten’
from /usr/local/lib/ruby/1.8/webrick/server.rb:63:in
initialize' from /usr/local/lib/ruby/1.8/webrick/httpserver.rb:24:ininitialize’
from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/webrick_server.rb
:58:in new' ... 7 levels... from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/commands/server.r b:39 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’
from ./script/server:3
www:~/webvz.2.0#


#6

Jan T. wrote:

Hallo Ralph,

On Mon, Oct 13, 2008 at 10:13:07AM +0200, Ralph Woermke wrote:

Leider geht immer noch nichts:

Firefox kann keine Verbindung zu dem Server unter 127.0.0.1:3000
aufbauen.

Firefox kann keine Verbindung zu dem Server unter 0.0.0.0:3000 aufbauen.

Firefox kann keine Verbindung zu dem Server unter localhost:3000
aufbauen.

Möglicherweise hast du eienn Proxy in Firefox aktiv, den du für
127.0.0.1
deaktivieren müsstest.

Hast du schon mal einen anderen Browser oder ein “telnet 127.0.0.1 3000”
probiert?

Jan


Jan T. Mail: removed_email_address@domain.invalid
ETES GmbH Fon : +49 (7 11) 48 90 83 - 17
Gablenberger Hauptstrasse 32 Fax : +49 (7 11) 48 90 83 - 50
D-70186 Stuttgart Web : http://www.etes.de/

Registergericht: Amtsgericht Stuttgart HRB 721182
Gesch�ftsf�hrende Gesellschafter: Markus Espenhain und Jan T.
Sitz der Gesellschaft: Stuttgart
USt.-Id.Nr.: DE814767446

HabeNeustart gemacht und der Fehler ist nun ersichtlich.

www:~# cd /root/webvz.2.0
www:~/webvz.2.0# ruby .script/server
ruby: No such file or directory – .script/server (LoadError)
www:~/webvz.2.0# ruby ./script/server
=> Booting WEBrick…
=> Rails 2.1.0 application started on http://0.0.0.0:3000
=> Ctrl-C to shutdown server; call with --help for options
[2008-10-13 10:37:08] INFO WEBrick 1.3.1
[2008-10-13 10:37:08] INFO ruby 1.8.6 (2008-08-08) [x86_64-linux]
[2008-10-13 10:37:08] WARN TCPServer Error: Address already in use -
bind(2)
/usr/local/lib/ruby/1.8/webrick/utils.rb:73:in initialize': Address already in use - bind(2) (Errno::EADDRINUSE) from /usr/local/lib/ruby/1.8/webrick/utils.rb:73:innew’
from /usr/local/lib/ruby/1.8/webrick/utils.rb:73:in
create_listeners' from /usr/local/lib/ruby/1.8/webrick/utils.rb:70:ineach’
from /usr/local/lib/ruby/1.8/webrick/utils.rb:70:in
create_listeners' from /usr/local/lib/ruby/1.8/webrick/server.rb:75:inlisten’
from /usr/local/lib/ruby/1.8/webrick/server.rb:63:in
initialize' from /usr/local/lib/ruby/1.8/webrick/httpserver.rb:24:ininitialize’
from
/usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/webrick_server.rb
:58:in new' ... 7 levels... from /usr/local/lib/ruby/gems/1.8/gems/rails-2.1.0/lib/commands/server.r b:39 from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:ingem_original_require’
from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require’
from ./script/server:3
www:~/webvz.2.0#


#7

http://www.morgen-licht.de:3000/
no such file to load – sqlite3
Wie es schaut musst du noch die sqlite3-ruby-bindings installieren


#8

Thomas W.|Formrausch wrote:

http://www.morgen-licht.de:3000/
no such file to load – sqlite3
Wie es schaut musst du noch die sqlite3-ruby-bindings installieren

Danke erstmal.

Ich installiere von /root aus. ruby, rubygems und sqlite3 liegen alle in
diesem Verzeichnis. Kannst du mir bitte sagen, in welches Verzeichnis
ich sqlite3 installieren muss? Krieg es noch nicht gebacken.

http://78.46.79.2:3000/

Gruß

Ralph


#9

Du hast sqlite3, rubygems und ruby richtig installiert?
Dann reicht ein

% sudo gem install sqlite3-ruby

Wenn nicht, dann solltest du dir erstmal ein nettes tutorial
suchen und deine entwicklungsumgebung fertigbauen.

http://hivelogic.com/articles/2008/02/ruby-rails-leopard
bzw. musste dir fuer dein OS was passendes suchen :slight_smile:


#10

Thomas W.|Formrausch wrote:

Du hast sqlite3, rubygems und ruby richtig installiert?
Dann reicht ein

% sudo gem install sqlite3-ruby

Wenn nicht, dann solltest du dir erstmal ein nettes tutorial
suchen und deine entwicklungsumgebung fertigbauen.

http://hivelogic.com/articles/2008/02/ruby-rails-leopard
bzw. musste dir fuer dein OS was passendes suchen :slight_smile:

ruby und rubygems sind richtig installiert. Lief ohne Fehlermeldung ab.

Das Problem ist sqlite3. Webvz hatte ich bereits vor Monaten einmal zum
testen installiert und es gab nicht die geringsten Probleme. Selbes OS,
selber Provider, selber Server. Inzwischen wurde andere
Virtualisierungssoftware ausprobiert. Bin aber zu OpenVz zurückgekehrt,
da es optimal ist. EasyVz als Gui kommt nicht in Frage zu komplexe und
schwierige Installation und es klemmt noch viel.
Also bin ich auch wieder zu Webvz zurückgekehrt. War simpel und
funktionierte.
Meine Umgebung machte bislang bei keiner anderen Anwendung Probleme.
Ich denke eher, daß es an meinem Verständnis liegt.
Wenn Du aber denken solltest, daß ich es mir leicht mache und einfach
das Forum für mich arbeiten lassen will, ist das nicht richtig. Ich
suche und lese mir jeweils einen Wolf, bevor ich irgend jemand frage.
Mit WebVz bin ich jetzt seit 2 Tagen unterwegs und habe jede Menge
ausprobiert. Viermal den Server clean aufgesetzt. Flutscht auch alles
ansonsten. Nunkomme ich aber nicht weiter und hab mich deshalb an euch
gewandt in der Hoffnung auf Hilfe. Hat bislang ja auch gut geklappt.
Meine erste Anfrage hätte ich uns aber ersparen können, wenn ich besser
hingesehen hätte. (webadresse, nicht localhost)Passiert manchmal, wenn
man sehr gestresst ist. Sorry.

also könntest Du Dich nochmal erbarmen?

Wäre sehr nett

Gruß

Ralph

www:~/sqlite3-ruby-1.2.3# ruby setup.rb config
—> lib
—> lib/sqlite3
—> lib/sqlite3/driver
—> lib/sqlite3/driver/dl
<— lib/sqlite3/driver/dl
—> lib/sqlite3/driver/native
<— lib/sqlite3/driver/native
<— lib/sqlite3/driver
<— lib/sqlite3
<— lib
—> ext
—> ext/sqlite3_api
/usr/local/bin/ruby /root/sqlite3-ruby-1.2.3/ext/sqlite3_api/extconf.rb
checking for fdatasync() in -lrt… yes
checking for sqlite3.h… no
*** /root/sqlite3-ruby-1.2.3/ext/sqlite3_api/extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=/root/sqlite3-ruby-1.2.3/ext/sqlite3_api
–curdir
–ruby=/usr/local/bin/ruby
–with-sqlite3-dir
–without-sqlite3-dir
–with-sqlite3-include
–without-sqlite3-include=${sqlite3-dir}/include
–with-sqlite3-lib
–without-sqlite3-lib=${sqlite3-dir}/lib
–with-rtlib
–without-rtlib
'system /usr/local/bin/ruby
/root/sqlite3-ruby-1.2.3/ext/sqlite3_api/extconf.rb
’ failed

Ich hab keine Ahnung welche Option ich wählen soll und nach welchen
Kriterien ich diese auswählen muss.

Die Linux-headers sind installiert. Welche libraries könnten denn
fehlen?

Gruß

Ralph


#11

Du hast auch sqlite3 selbst und nicht nur die dev-header installiert?
Soweit ich das beim drueberfliegen sehen konnte, findet er ja sqlite3
selbst nicht, oder? Hast du denn alles per Hand installiert oder nutzt
du
sowas fuer apt oder yum oder oder?
Sorry, dass ich dir da grad nicht so genau weiterhelfen kann,
fernwartung
ist immer etwas schwierig. :slight_smile:

Andere Frage: Warum willst du sqlite benutzen? Fuer einen
Produktionsserver
ist das eher weniger geeignet, da beim schreiben die DB gelock(t/ed)
wird.
(http://www.sqlite.org/faq.html punkt 5.)
Fuer die Entwicklung auf deinem lokalen Rechner ist aber natuerlich
geeignet.

On Oct 13, 2008, at 12:05 PM, Ralph Woermke wrote:

bzw. musste dir fuer dein OS was passendes suchen :slight_smile:
zurückgekehrt,
ausprobiert. Viermal den Server clean aufgesetzt. Flutscht auch alles

—> lib/sqlite3/driver/native
*** /root/sqlite3-ruby-1.2.3/ext/sqlite3_api/extconf.rb failed ***
–with-opt-lib
–with-sqlite3-lib

rubyonrails-ug mailing list
removed_email_address@domain.invalid
http://mailman.headflash.com/mailman/listinfo/rubyonrails-ug


Thomas W.

Formrausch GmbH
Geschäftsfuehrer: Stefan Ternes, Thomas W.

Pfarrer-Kraus-Straße 127e // 56077 Koblenz
Amtsgericht Koblenz HRB 20159

Buero Koblenz // Löhrstraße 1 // 56068 Koblenz

fon +49 261 973 36 16
fax +49 261 973 36 43

removed_email_address@domain.invalid
www.formrausch.com


#12

Thomas W.|Formrausch wrote:

Du hast auch sqlite3 selbst und nicht nur die dev-header installiert?
Soweit ich das beim drueberfliegen sehen konnte, findet er ja sqlite3
selbst nicht, oder? Hast du denn alles per Hand installiert oder nutzt
du
sowas fuer apt oder yum oder oder?
Sorry, dass ich dir da grad nicht so genau weiterhelfen kann,
fernwartung
ist immer etwas schwierig. :slight_smile:

Andere Frage: Warum willst du sqlite benutzen? Fuer einen
Produktionsserver
ist das eher weniger geeignet, da beim schreiben die DB gelock(t/ed)
wird.
sqlite wurde verlangt,wenn eine Fehlermeldung auftauchte.
War aber immer unter 0.0.0.0:3000
Tun sollte er´s aber unter www-morgen-licht oder 78.46.79.2

Habe alles von hand installiert. Sqlite zuletzt auch mit gems


Thomas W.

Formrausch GmbH
Gesch�ftsfuehrer: Stefan Ternes, Thomas W.

Pfarrer-Kraus-Stra�e 127e // 56077 Koblenz
Amtsgericht Koblenz HRB 20159

Buero Koblenz // L�hrstra�e 1 // 56068 Koblenz

fon +49 261 973 36 16
fax +49 261 973 36 43

removed_email_address@domain.invalid
www.formrausch.com


#13

Hi,

Bewegen wir uns noch auf einem development system oder auf auf
dem Produktiv-Server?

Für den Produktiv-Server brauchst du entweder nginx/lighttpd mit
mongrels
oder einfach mod_rails mit apache2.
Diese eine Schicht ist auf Produktivservern immer dazwischen weil zum
einen mehrere mongrels/mod_rail prozesse ablaufen sollen und man alle
über den normalen port 80 erreichen will.

ciao, tom

Am 13.10.2008 um 12:29 schrieb Ralph Woermke:

sqlite wurde verlangt,wenn eine Fehlermeldung auftauchte.
War aber immer unter 0.0.0.0:3000
Tun sollte er´s aber unter www-morgen-licht oder 78.46.79.2


Thomas R. “TomK32” Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32


#14

Das eine ist eine lokale IP, das andere die IP ‘nach außen’, das hat
ersmal nix miteinander
zu tun. Ob deine Anwendung dann auch unter der 78.46.79.2 erreichbar
ist,
haengt dann nur mit der Firewall und den Ports ab. ausserdem kommt man
doch
ueber www-morgen-licht:3000 drauf. wo ist das problem?

wenn du die anwendung auf die 80 legen magst, dann musst du entweder
den apache/nginx/lighttpd abschalten,
was aber keine gute idee ist oder viel besser weiter proxy-en.

(Ich nehm einfach mal an, du redest gerade immer von deinem Production-
Server)


http://www.isi.edu/in-notes/rfc3330.txt:
0.0.0.0/8 - Addresses in this block refer to source hosts on “this”
network. Address 0.0.0.0/32 may be used as a source address for this
host on this network; other addresses within 0.0.0.0/8 may be used to
refer to specified hosts on this network [RFC1700, page 4].


#15

Thomas W.|Formrausch wrote:

Das eine ist eine lokale IP, das andere die IP ‘nach au�en’, das hat
ersmal nix miteinander
zu tun. (Das ist mir klar.) Ob deine Anwendung dann auch unter der
78.46.79.2 erreichbar
ist,
haengt dann nur mit der Firewall und den Ports ab. ausserdem kommt man
doch
ueber www-morgen-licht:3000 drauf. wo ist das problem?

wenn du die anwendung auf die 80 legen magst, dann musst du entweder
den apache/nginx/lighttpd abschalten,
was aber keine gute idee ist oder viel besser weiter proxy-en.

(Ich nehm einfach mal an, du redest gerade immer von deinem Production-
Server) Ja.

Ansonsten erstmal herzlichen Dank. Werd mich nun drum kümmern. Hab eure
Zeit vorerst lange genug in Anspruch genommen. Aus euren Antworten ist
nun aber klar geworden, wo das Problem liegt: Zuerst mal in meinem
Verständnis, dem nun ein Stück auf die Sprünge geholfen wurde. Danke
nochmals

Ralph


http://www.isi.edu/in-notes/rfc3330.txt:
0.0.0.0/8 - Addresses in this block refer to source hosts on “this”
network. Address 0.0.0.0/32 may be used as a source address for this
host on this network; other addresses within 0.0.0.0/8 may be used to
refer to specified hosts on this network [RFC1700, page 4].


#16

Thomas R. Koll wrote:

Hi,

Bewegen wir uns noch auf einem development system oder auf auf
dem Produktiv-Server?

F�r den Produktiv-Server brauchst du entweder nginx/lighttpd mit
mongrels
oder einfach mod_rails mit apache2.
Diese eine Schicht ist auf Produktivservern immer dazwischen weil zum
einen mehrere mongrels/mod_rail prozesse ablaufen sollen und man alle
�ber den normalen port 80 erreichen will.

ciao, tom

Wir bewegen uns auf einem Produktionsserver jetzt.
Danke für die Hilfe. Ich mach mich jetzt dann wieder an die Arbeit und
melde mich nochmal. Natürlich auch, wenn´s geklappt hat
Bis dann und einen wirklich schönen Tag noch für euch beide

Gruß

Ralph

Am 13.10.2008 um 12:29 schrieb Ralph Woermke:

sqlite wurde verlangt,wenn eine Fehlermeldung auftauchte.
War aber immer unter 0.0.0.0:3000
Tun sollte er�s aber unter www-morgen-licht oder 78.46.79.2


Thomas R. “TomK32” Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32


#17

einfach ganz unten rein :slight_smile:


#18

Thomas W.|Formrausch wrote:

einfach ganz unten rein :slight_smile:

Danke! hat geklappt.

Kann ich in diese Datei auch einen virtuellen Host in dieser Form
anlegen

<VirtualHost *:80>
ServerName www.yourhost.com
DocumentRoot /somewhere/public

oder muss das unter /var/www/ bzw. /var/rails sein?

Ralph


#19

Ralph Woermke wrote:

Thomas R. Koll wrote:

Hi,

Bewegen wir uns noch auf einem development system oder auf auf
dem Produktiv-Server?

F�r den Produktiv-Server brauchst du entweder nginx/lighttpd mit
mongrels
oder einfach mod_rails mit apache2.
Diese eine Schicht ist auf Produktivservern immer dazwischen weil zum
einen mehrere mongrels/mod_rail prozesse ablaufen sollen und man alle
�ber den normalen port 80 erreichen will.

So weit bin ich jetzt:

The Apache 2 module was successfully installed.

Please edit your Apache configuration file, and add these lines:

LoadModule passenger_module
/usr/local/lib/ruby/gems/1.8/gems/passenger-2.0.3/ext/apache2/mod_passenger.so
PassengerRoot /usr/local/lib/ruby/gems/1.8/gems/passenger-2.0.3
PassengerRuby /usr/local/bin/ruby

After you restart Apache, you are ready to deploy any number of Ruby on
Rails
applications on Apache, without any further Ruby on Rails-specific
configuration!

Mir ist jetzt nicht klar, an welcher Stelle in/etc/apache2/apache2.conf
ich diese Zeilen

LoadModule passenger_module
/usr/local/lib/ruby/gems/1.8/gems/passenger-2.0.3/ext/apache2/mod_passenger.so
PassengerRoot /usr/local/lib/ruby/gems/1.8/gems/passenger-2.0.3
PassengerRuby /usr/local/bin/ruby

einfügen soll.
Eine weitere Frage ist, ob sie genau so, in der Form wie sie da stehen,
eingefügt werden sollen.

Könnt ihr mir hier bitte weiterhelfen?

Gruß

Ralph

P.S.
Da habt ihr mich ja auf ein dolles Ding gebracht. Bin schon ganz
unruhig.

ciao, tom

Wir bewegen uns auf einem Produktionsserver jetzt.
Danke für die Hilfe. Ich mach mich jetzt dann wieder an die Arbeit und
melde mich nochmal. Natürlich auch, wenn´s geklappt hat
Bis dann und einen wirklich schönen Tag noch für euch beide

Gruß

Ralph

Am 13.10.2008 um 12:29 schrieb Ralph Woermke:

sqlite wurde verlangt,wenn eine Fehlermeldung auftauchte.
War aber immer unter 0.0.0.0:3000
Tun sollte er�s aber unter www-morgen-licht oder 78.46.79.2


Thomas R. “TomK32” Koll || http://tomk32.de || http://ananasblau.com
just a geek trying to change the world
Skype: TomK32 || Mail: removed_email_address@domain.invalid
http://beta.lomography.com/homes/TomK32