Address family for hostname not supported

I tried to do a cap deploy yesterday when it suddenly didn’t want to
work anymore.
It says “address family for hostname not supported”. After a lot of
searching and googling and source code lookup I came to the following:
On my development machine @ work (Windows 2003) there is a problem with
the low level Socket.getnameinfo() call.
When I try to do a Socket.getnameinfo([‘AF_INET’, ‘22’, ‘beeplet.com’])
I get the above exception. but a Socket.getnameinfo([‘AF_INET’, ‘23’,
beeplet.com’]) it works like a charm. It doesn’t have anything to do
with what domain I use, it only happens when I use port 22 (ssh) in the
method call. Everything worked fine 2 days ago and now, suddenly, it
bails on me.
Doing the above method call from my development machine @ home (Ubuntu)
it all works just fine.

I don’t know how and why I get this exception and haven’t been able to
find a sollution either. Maybe somebody knows something more on this
topic?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs