Adding OOT Modules from Github

Hello,

I am trying to use the Burst PSK project that Tim O’Shea and Kiran K.
developed and I am having trouble figuring out how to add the projects’
blocks into my version of Gnuradaio. Is there an easy way to add
multiple
blocks at a time or is it necessary to add them one at a time (using the
method described in the OOT tutorial)?

I haven’t tried much in the way of solving this problem because I would
consider myself a novice when it comes to Linux but a hint in the right
direction would definitely be welcomed.

I appreciate your time,

Logan Washbourne
Electrical Engineering Graduate Student
(Electromagnetics)

PyBOMBS is your friend. https://github.com/gnuradio/pybombs

On Tue, Jun 23, 2015 at 1:21 PM, Washbourne, Logan <

How did you go about installing GNU Radio, and what version are you
using?
(Check gnuradio-companion’s version).

On Tue, Jun 23, 2015 at 4:21 PM, Washbourne, Logan <

Start with “./pybombs sync” to pull town the latest recipes. You
probably
have old recipes.
If you’re running 3.7.3 you may as well wipe out the old build and start
fresh.

On Tue, Jun 23, 2015 at 1:33 PM, Washbourne, Logan <

“inventory.dat” contains the state of all the installed packages; you
could
edit it or just remove it and restart your builds.

On Tue, Jun 23, 2015 at 2:06 PM, Washbourne, Logan <

Chris,

I appreciate the quick reply. I should have mentioned more in my first
email. Pybombs was my initial route I was going to take but when I run
“./pybombs list” gr-psk-burst is not listed. Although it is listed on
the
CGRAN website.

Tim,

I am running GRC 3.7.3, and I am 95% sure I used Pybombs a couple of
months
ago to install gnuradio.

Logan Washbourne
Electrical Engineering Graduate Student
(Electromagnetics)

On Tue, Jun 23, 2015 at 3:24 PM, Chris K. [email protected]

Chris,

Thanks for the advice. I ended up reinstalling Ubuntu 14.04, because I
had
not installed gnuradio through pybombs originally and I prematurely
deleted
the build folder for gnuradio before I could cleanly remove it. Now
everything works great though, since I stuck to installing everything
through pybombs.

Again, I really appreciate your help,

Logan Washbourne
Electrical Engineering Graduate Student
(Electromagnetics)

On Tue, Jun 23, 2015 at 5:33 PM, Chris K. [email protected]

Chris,

I took your advice and uninstalled Gnuradio (to the best of my
knowledge, I
prematurely deleted the build folder before I could do a clean
uninstall,
so I searched around and deleted every instance of Gnuradio I could
find,
which I’m sure is the worst way to do it). When I try to install
Gnuradio
from Pybombs, I get an error stating:

[email protected]:~/Logan/source/pybombs$ ./pybombs install gnuradio -v
Settled on prefix: /home/comm1/Logan/source/target
Loading recipes …
Checking if gnuradio is installed: No
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of make (4.0) is >= than 3.75
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libboost-dev (1.55.0) is >= than 1.53
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libboost-date-time-dev (1.55.0) is >= than 1.53
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libboost-filesystem-dev (1.55.0) is >= than 1.53
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libboost-program-options-dev (1.55.0) is >= than 1.53
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libboost-regex-dev (1.55.0) is >= than 1.53
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libboost-thread-dev (1.55.0) is >= than 1.53
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libboost-test-dev (1.55.0) is >= than 1.53
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libgsl0-dev (1.16) is >= than 1.13
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of libgsl0ldbl (1.16) is >= than 1.13
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-cheetah (2.4.4) is >= than 2.0
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-numpy (1.8.2) is >= than 1.5
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-lxml (3.3.6) is >= than 2.3.2
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-gtk2 (2.24.0) is >= than 2.17
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-cairo-dev (1.8.8) is >= than 1.8
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of cmake (2.8.12) is >= than 2.8.3
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of cmake-data (2.8.12) is >= than 2.8.3
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-qt4 (4.11.2) is >= than 4.6.2
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-qwt5-qt4 (5.2.1) is >= than 5.2
PyBombs.sysutils - INFO - have_deb: Satisfies requirement…installed
version of python-zeroc-ice (3.5.1) is >= than 3.5
Installing packages:

  • gnuradio
    Installing from source: gnuradio
    – Build type set to RelWithDebInfo.
    – Extracting version information from git describe…
    – Compiler Version: gcc (Ubuntu 4.9.1-16ubuntu6) 4.9.1
    Copyright © 2014 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions. There is
    NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
    PURPOSE.
    – Compiler Flags: /usr/bin/gcc:::-O2 -g -DNDEBUG -fvisibility=hidden
    -Wsign-compare -Wall -Wno-uninitialized
    /usr/bin/g++:::-O2 -g -DNDEBUG -fpermissive -fvisibility=hidden
    -Wsign-compare -Wall -Wno-uninitialized
    – ADDING PERF COUNTERS
    – Building Static Libraries: OFF
    – Boost version: 1.55.0
    – Found the following Boost libraries:
    – date_time
    – program_options
    – filesystem
    – system
    – thread

    – Checking for module SWIG
    – Found SWIG version 2.0.12.

    – The build system will automatically enable all components.
    – Use -DENABLE_DEFAULT=OFF to disable components by default.

    – Configuring python-support support…
    – Dependency PYTHONLIBS_FOUND = TRUE
    – Dependency SWIG_FOUND = TRUE
    – Dependency SWIG_VERSION_CHECK = TRUE
    – Enabling python-support support.
    – Override with -DENABLE_PYTHON=ON/OFF

    – Configuring testing-support support…
    – Dependency CPPUNIT_FOUND = TRUE
    – Enabling testing-support support.
    – Override with -DENABLE_TESTING=ON/OFF

    – Configuring VOLK support…
    – VOLK submodule is not checked out.
    – To check out the VOLK submodule, use:
    – git pull --recurse-submodules=on
    – git submodule update
    – External VOLK disabled.
    – Override with -DENABLE_INTERNAL_VOLK=ON/OFF

    CMake Error at CMakeLists.txt:310 (message):
    VOLK required but not found.

– Configuring incomplete, errors occurred!
See also
“/home/comm1/Logan/source/pybombs/src/gnuradio/build/CMakeFiles/CMakeOutput.log”.
Configuration failed. Re-trying with higher verbosity.
make: *** No targets specified and no makefile found. Stop.
Build failed. See output above for error messages.

I can run the Volk Profiler though so I’m not sure why it can’t find
Volk.

Got any advice?

Logan Washbourne
Electrical Engineering Graduate Student
(Electromagnetics)

On Tue, Jun 23, 2015 at 3:39 PM, Chris K. [email protected]

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs