Added a :default_server_url setting to blog


#1

For those of you living on the edge, after you update to revision
1046, please go to your general settings page and make sure that
it makes a good guess at your canonical server url and either accept
or correct it and hit save (whether you corrected it or not).

This is a new fallback setting for the Blog. I don’t believe it
affects any production stuff yet, but there are some tests that
fail without this setting being available on the blog (the fixture
sets something appropriately). However, in the long run, I expect that
this setting will get used more often (in fact, I can see it, or
something like it, getting promoted to a proper column on the ‘blogs’
table for use by the dispatcher in a multi blog environment.


#2

On Thursday 11 May 2006 20:12, Piers C. wrote:

something like it, getting promoted to a proper column on the ‘blogs’
table for use by the dispatcher in a multi blog environment.

Out of curiosity, how does this affect those of us who access the same
blog
through both normal HTTP (for all public stuff) and HTTPS (for all admin
pages)?

TX


#3

Trejkaz removed_email_address@domain.invalid writes:

this setting will get used more often (in fact, I can see it, or
something like it, getting promoted to a proper column on the ‘blogs’
table for use by the dispatcher in a multi blog environment.

Out of curiosity, how does this affect those of us who access the same blog
through both normal HTTP (for all public stuff) and HTTPS (for all admin
pages)?

Err… I think in the long run, the setting will end up being
‘canonical_server’. Until then, about the only thing you’ll need to do
is change ‘https’ in the suggested canonical server url to ‘http’