Acts_as_taggable Produces Bad SQL - Find Fails


I am using acts_as_taggable in my application and on the tagging side of
things, no problem at all. Running edge Rails and PostgreSQL 8.1.

I am then trying to find all my AR objects with a certain tag. The tag
lasvegas and I know that there are at least 3 records with that tag.

So, I’m doing this:

@lists = List.find_tagged_with :any => @search_string, :separator => ‘+’

The problem is that the SQL generated looks like this:

SELECT lists.* FROM lists, tags, taggings WHERE =
taggings.taggable_id AND taggings.taggable_type = ‘List’ AND
= AND IN (‘anylasvegas’, ‘separator+’)

See what’s right after the IN clause? It says ‘anylasvegas’ - why? BTW,
using ‘lasvegas’ returns the correct results.

I used the :any symbol in the finder per the instructions and all the
permutations I tried to get rid of it just gave me syntax errors, etc…

So, am I doing something wrong or what?



This patch might help:




Excellent, I’ll give this a go, thanks.

Anyone know the best way to install this patch?

I tried simply commenting out the old method in the plugin and inserting
this but I get this exception:

undefined method `split_tag_names’ for

Indeed, looking at the plug-in I don’t see that method defined

What gives?



yeah, i’m having problems, too. i get an error with a later function
in the gem. any help would be appreciated.