Acts_As_Ferret only returns results when searching for "*"

Hey, I’m probably just missing something really obvious but I’ve been
stuck on this problem for a while now and I’m not getting anywhere.

I have installed the acts_as_ferret gem, as well as ferret according to
the tutorial on RailsEnvy. My model, controller, and environment.rb
files have all been modified as per that turotial. However any attempts
to use the find_by_contents on my model returns 0 results unless I am
doing Article.find_by_contents("*"), with Article being my model.
Searching for * will return all records from the database.

In the Article model I have the “acts_as_ferret” with no fields
specified as I was under the impression that this would index all
fields. I’ve also tried specifying specific fields which still yielded
the same error.

Has anyone else run into this problem?


Please have a look in your log files (development.log and
ferret_index.log), maybe we can see what’s going on


On Thu, Jul 19, 2007 at 05:29:42PM +0200, Chelsea Robb wrote:

In the Article model I have the “acts_as_ferret” with no fields
[email protected]

Jens Krämer - Blog - The new free film database