Acts_as_authentificated signup problem don't understand logs


I just put in production my application and i have to deal with a
problem which didn’t exist before and I can’t find the cause in the

I’m using rails 1.2.3 (the application was started with this version)
and the plugin ‘acts_as_authentificated’ to manage my users.
I added, by following the documentation, the email validation, password
changes and the password reset in case the user loose it.

Every thing was working fine on the server (development mode and in
local with locomotive.

But now (after a few changes which didn’t touch the authentification
system) the signup do not work in local or in the server

In development mode, it was a error about ‘apssword_reset_code’ which
couldn’t be NULL but even by admiting NULL in Mysql, the signup still do
not work. In local, the user is add to the database but the validation
email isn’t sent and the page just block without showing a error. In
production I have the page ‘something wrong happened’ and the user isn’t
added to the database.

there is the log:

[CODE]Processing AccountController#signup (for at 2009-02-04
23:56:08) [POST]
Session ID: 816e87e453f0da2bf08b05882044c3d7
Parameters: {“user”=>{“premieresession”=>“2008”, “trimestre”=>“1”,
“nom”=>“xxx”, “groupe_id”=>“13”, “password_confirmation”=>“xxx”,
“type_id”=>“1”, “login”=>“xxx”, “password”=>“xxx”,
“email”=>“[email protected]”}, “commit”=>“S’inscrire”, “action”=>“signup”,
e[4;35;1mAssociation Load (0.000905)e[0m e[0mSELECT * FROM
associations ORDER BY nome[0m
e[4;36;1mGroupe Load (0.000305)e[0m e[0;1mSELECT * FROM groupes e[0m
e[4;35;1mUser Columns (0.002179)e[0m e[0mSHOW FIELDS FROM userse[0m
e[4;36;1mSQL (0.000169)e[0m e[0;1mBEGINe[0m
e[4;35;1mUser Load (0.000387)e[0m e[0mSELECT * FROM users WHERE
(LOWER(users.login) = ‘achille6’) LIMIT 1e[0m
e[4;36;1mUser Load (0.001560)e[0m e[0;1mSELECT * FROM users WHERE
(LOWER( = ‘[email protected]’) LIMIT 1e[0m
e[4;35;1mSQL (0.012565)e[0m e[0mINSERT INTO users
(premieresession, salt, activated_at, nom, trimestre,
updated_at, crypted_password, groupe_id, activation_code,
admin, remember_token_expires_at, type_id, groupe_accept,
password_reset_code, remember_token, login, created_at, email)
VALUES(‘2008’, ‘f3477f457e81f9fb4e32612e8c632fa3dc5583cb’, NULL, ‘xxx’,
1, ‘2009-02-04 23:56:08’, ‘1d0fa63a811191428c60b858bc4b9ea35f3a0bb1’,
13, ‘4bf7cbb38d26fe5e8e6995922dde156ffc47d2cd’, 0, NULL, 1, 0, NULL,
NULL, ‘xxx’, ‘2009-02-04 23:56:08’, ‘[email protected]’)e[0m
Sent mail:
Date: Wed, 4 Feb 2009 23:56:08 +0100
From: [email protected]
To: [email protected]
Subject: Portail AEHEC - Activation de votre compte
Mime-Version: 1.0
Content-Type: text/plain; charset=utf-8


Ton compte a été créé avec succès.
Voici tes identifiants:

Utilisateur: xxx
Mot de passe: xxx

Avant de pouvoir utiliser ton compte, tu dois l’activer en cliquant sur
ce lien:

Ou en rentrant ton code d’activation à cette adresse:
Ton code d’activation:4bf7cbb38d26fe5e8e6995922dde156ffc47d2cd
e[4;36;1mSQL (0.008250)e[0m e[0;1mCOMMITe[0m

If you have even if a little idea of the problem, it could help a lot !
I’m completely lost and the error just show up at the worst moment just
after the lauch of the website.

I just tried with a stable version when i was sure the signup was
working and even the stable version it’s not working.

Thanks a lot !!

Hey Achille,

There’s not information to get to the bottom of this. Could you please
paste the log when the error occurs? You may also find it helpful if
you install the exception_notification plugin. It emails you whenever
an error occurs with all the details you need to know to fix it. Check
it out here:


On Feb 5, 6:54 am, Achille P. [email protected]

Hey Ahmed !

Thanks for the answer !
The problem is that I do not have an error. The browser just freeze.
And the logs just stops. I tried the pluggin exception_notifier and it
is even worse …
The application don’t start after I unsucessfully tried to signup.

I guess it may be a problem with emails, because in the logs, stop right
after writing the validation email and the exception_notifier deals with

But I’m still lost.

Have you followed the the wiki?

You can also add the debug view, by changin the deployment and det
debug to true, just like in development.
Please also note, to change the mail settings to reflext the
deployment enviroment.


On Feb 5, 5:49 pm, Achille P. [email protected]

I have follow the wiki.
Everything was working perfectly so really don’t know what’s happening.

The debug view ?
In development mode, I do not got any error. The page just freeze.
In production, I’ve got the error ‘We’re sorry, but something went
I’m using Locomotive on Mac OS 10.5

Is there a possibily to obtain more information about what’s going wrong
in development mode when i do not get a error and the logs aren’t
showing any error ?

For the mail settings, I was using a defaut configuration and it was
working both in local and in the server.

look in your

you see the following files:
production.rb ← correct this file to debig = true, look at your
development for instriration…


On Feb 5, 7:12 pm, Achille P. [email protected]