Activerecord-sqlserver-adapter and Rails 3

Does activerecord-sqlserver-adapter work with Rails 3 RC?
I get bunch of warning and then an exception:

D:\temp>ruby -v adapter.rb
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/i18n-0.4.1/lib/i18n/core_ext/string/interpolate.rb:11:
warning: too many arguments for format string
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/relation.rb:101:
warning: shadowing outer local variable - attribute
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/utilities/compound.rb:36:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/operations/lock.rb:6:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/relations/table.rb:6:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/christener.rb:6:
warning: shadowing outer local variable - relation
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/memory/relations/array.rb:9:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:366:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:870:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:880:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:973:
warning: shadowing outer local variable - rows
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/pathname.rb:270:
warning: `*’ interpreted as argument prefix
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/json/common.rb:274:
warning: method redefined; discarding old recurse_proc

D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:in
alias_method': undefined methodadd_order!’ for class Class' (NameError) from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:inalias_method_chain’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:14:in
singletonclass' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:12:inincluded’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in
include' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in<top (required)>’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:in
require' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inblock in require’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
block in load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:570:innew_constants_in’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:3:in
<top (required)>' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:in
<top (required)>' from adapter.rb:2:inrequire’
from adapter.rb:2:in `’

Tomas

Forgot to mention that adapter.rb just requires:
require ‘active_record’
require ‘activerecord-sqlserver-adapter’

Tomas

From: [email protected]
[mailto:[email protected]] On Behalf Of Tomas M.
Sent: Thursday, August 19, 2010 11:44 AM
To: [email protected]
Subject: [Ironruby-core] activerecord-sqlserver-adapter and Rails 3

Does activerecord-sqlserver-adapter work with Rails 3 RC?
I get bunch of warning and then an exception:

D:\temp>ruby -v adapter.rb
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/i18n-0.4.1/lib/i18n/core_ext/string/interpolate.rb:11:
warning: too many arguments for format string
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/relation.rb:101:
warning: shadowing outer local variable - attribute
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/utilities/compound.rb:36:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/operations/lock.rb:6:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/relations/table.rb:6:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/christener.rb:6:
warning: shadowing outer local variable - relation
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/memory/relations/array.rb:9:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:366:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:870:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:880:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:973:
warning: shadowing outer local variable - rows
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/pathname.rb:270:
warning: `*’ interpreted as argument prefix
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/json/common.rb:274:
warning: method redefined; discarding old recurse_proc

D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:in
alias_method': undefined methodadd_order!’ for class Class' (NameError) from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:inalias_method_chain’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:14:in
singletonclass' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:12:inincluded’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in
include' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in<top (required)>’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:in
require' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inblock in require’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
block in load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:570:innew_constants_in’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:3:in
<top (required)>' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:in
<top (required)>' from adapter.rb:2:inrequire’
from adapter.rb:2:in `’

Tomas

I think it works with the latest Rails 3:
http://groups.google.com/group/rails-sqlserver-adapter/browse_thread/thread/367cf70b2b48d4a0
~Jimmy

On Thu, Aug 19, 2010 at 2:43 PM, Tomas M. <

Hi Tomas, do you get the same outcome under 1.8.7 or 1.9.2? There are
some
caveats in the release notes about Rails 3 incompatibility under 1.9.1 @
http://edgeguides.rubyonrails.org/3_0_release_notes.html#rails-3-requires-at-least-ruby-187

On Thu, Aug 19, 2010 at 2:43 PM, Tomas M. <

I don’t have 1.9.2 binaries – is there a build for Windows somewhere?
I need 1.9 version so that I can prepare the test suites for IronRuby,
which is now 1.9 only.

Tomas

From: [email protected]
[mailto:[email protected]] On Behalf Of Eddie Cianci
Sent: Thursday, August 19, 2010 12:30 PM
To: [email protected]
Subject: Re: [Ironruby-core] activerecord-sqlserver-adapter and Rails 3

Hi Tomas, do you get the same outcome under 1.8.7 or 1.9.2? There are
some caveats in the release notes about Rails 3 incompatibility under
1.9.1 @
http://edgeguides.rubyonrails.org/3_0_release_notes.html#rails-3-requires-at-least-ruby-187

On Thu, Aug 19, 2010 at 2:43 PM, Tomas M.
<[email protected]mailto:[email protected]>
wrote:
Does activerecord-sqlserver-adapter work with Rails 3 RC?
I get bunch of warning and then an exception:

D:\temp>ruby -v adapter.rb
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/i18n-0.4.1/lib/i18n/core_ext/string/interpolate.rb:11:
warning: too many arguments for format string
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/relation.rb:101:
warning: shadowing outer local variable - attribute
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/utilities/compound.rb:36:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/operations/lock.rb:6:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/relations/table.rb:6:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/christener.rb:6:
warning: shadowing outer local variable - relation
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/memory/relations/array.rb:9:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:366:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:870:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:880:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:973:
warning: shadowing outer local variable - rows
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/pathname.rb:270:
warning: `*’ interpreted as argument prefix
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/json/common.rb:274:
warning: method redefined; discarding old recurse_proc

D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:in
alias_method': undefined methodadd_order!’ for class Class' (NameError) from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:inalias_method_chain’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:14:in
singletonclass' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:12:inincluded’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in
include' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in<top (required)>’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:in
require' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inblock in require’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
block in load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:570:innew_constants_in’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:3:in
<top (required)>' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:in
<top (required)>' from adapter.rb:2:inrequire’
from adapter.rb:2:in `’

Tomas


Ironruby-core mailing list
[email protected]mailto:[email protected]
http://rubyforge.org/mailman/listinfo/ironruby-core

OK, so taking the master snapshot from sqlserver-adapter GIT repo fixed
it.
Now, I need ruby-odbc native extension binary for Windows :-/.

Tomas

From: [email protected]
[mailto:[email protected]] On Behalf Of Jimmy
Schementi
Sent: Thursday, August 19, 2010 12:12 PM
To: [email protected]
Subject: Re: [Ironruby-core] activerecord-sqlserver-adapter and Rails 3

I think it works with the latest Rails 3:
http://groups.google.com/group/rails-sqlserver-adapter/browse_thread/thread/367cf70b2b48d4a0
~Jimmy

On Thu, Aug 19, 2010 at 2:43 PM, Tomas M.
<[email protected]mailto:[email protected]>
wrote:
Does activerecord-sqlserver-adapter work with Rails 3 RC?
I get bunch of warning and then an exception:

D:\temp>ruby -v adapter.rb
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/i18n-0.4.1/lib/i18n/core_ext/string/interpolate.rb:11:
warning: too many arguments for format string
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/relation.rb:101:
warning: shadowing outer local variable - attribute
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/utilities/compound.rb:36:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/algebra/relations/operations/lock.rb:6:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/relations/table.rb:6:
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/sql/christener.rb:6:
warning: shadowing outer local variable - relation
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/memory/relations/array.rb:9:
warning: method redefined; discarding old initialize
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:366:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:870:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:880:
warning: unused literal ignored
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:973:
warning: shadowing outer local variable - rows
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/pathname.rb:270:
warning: `*’ interpreted as argument prefix
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/1.9.1/json/common.rb:274:
warning: method redefined; discarding old recurse_proc

D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:in
alias_method': undefined methodadd_order!’ for class Class' (NameError) from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/core_ext/module/aliasing.rb:31:inalias_method_chain’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:14:in
singletonclass' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:12:inincluded’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in
include' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter/core_ext/active_record.rb:145:in<top (required)>’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:in
require' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inblock in require’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
block in load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:570:innew_constants_in’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
load_dependency' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:219:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/active_record/connection_adapters/sqlserver_adapter.rb:3:in
<top (required)>' from D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:inrequire’
from
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activerecord-sqlserver-adapter-2.3.8/lib/activerecord-sqlserver-adapter.rb:1:in
<top (required)>' from adapter.rb:2:inrequire’
from adapter.rb:2:in `’

Tomas

You can find an experimental build of RubyInstaller based on 1.9.2-rc1
(see http://rubyforge.org/frs/?group_id=167), but a new release for
1.9.2-p0 is around the corner.

On Thu, Aug 19, 2010 at 23:10, Tomas M.
[email protected] wrote:

D:\temp>ruby -v adapter.rb
warning: method redefined; discarding old engine
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/arel-0.4.0/lib/arel/engines/memory/relations/array.rb:9:

`<top (required)>’
D:/M2/dlr/External.LCA_RESTRICTED/Languages/Ruby/ruby19/lib/ruby/gems/1.9.1/gems/activesupport-3.0.0.rc/lib/active_support/dependencies.rb:205:in
       from

Tomas


Ironruby-core mailing list
[email protected]
http://rubyforge.org/mailman/listinfo/ironruby-core


Daniele A.
http://clorophilla.net/
http://twitter.com/JoL1hAHN

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs