Activerecord - mysql blobs


#1

I’m struggling with activerecord and mysql blobs (uploading files)…

blobs over 400K-ish cause the below exception…

ActiveRecord::StatementInvalid in File#upload

Mysql::Error: Lost connection to MySQL server during query:

I’ve tried blob, mediumblob, and longblob…

I’m using windows xp for development - and have not installed the mysql
gem…

simlar google postings/solutions have not worked

thoughts/suggestions?


#2

Suggestion to use file_column… Sorry if you can’t do this… I’m pretty
sure any DB expert will say you storing blobs in database must suck.


#3

I’m fighting the exact same issue right now myself - so very
interested in seeing if someone comes back with an answer for it.

I did find some old posts here in the mailing list that suggest that
error has to do with some buggy mysql bindings in windows and pointed
to this page

http://wiki.rubyonrails.org/rails/pages/HowToUseMySQLRubyBindingsOnWin32/

i installed the dll bu haven’t gotten it to work yet. Was also going
to try porting the code over to my linux webserver either tonight /
tommorow to see if the problem does go away once it’s off of XP.


#4

Update - looks like I was able to solve my issue by merely increasing
the mysql max_allowed_packet parameter.

hopefully that’ll solve yours too

-Eldon


#5

very cool - that worked…

  • Barinek