Activerecord installation

when i try to install activerecord gem on ironruby, i’ve got:

igem install activerecord -r --no-rdoc --no-ri
ERROR: Error installing activerecord:
activesupport requires Ruby version >= 1.8.7

(‘ir.exe -e “puts RUBY_VERSION”’ returns ‘1.8.6’)

may be i can change ruby version in igem to 1.9.1?
or there is another way?

I ran previously with the same problem, add the version that works.

try:

igem install activerecord -v 2.3.8 --no-rdoc --no-ri

Eduardo

i can run “ir.exe -1.9” and RUBY_VERSION will be 1.9.1
but by default (and in “igem” RUBY_VERSION is 1.8.6 by default.
perhaps there is a way to set ruby version for “igem” (and for “iirb”)
or change running default arguments?

Right, if you use the current binaries (1.0 or 1.1) the compatibility is
with MRI 1.8.6.
If you build the latest source from GIT repo you’ll get 1.9.2 compatible
IronRuby.

Tomas

As I understand it, Ruby 1.9 compat in IronRuby 1.0 and 1.1 was not all
that
complete. So, even if you force them into 1.9 mode, things may break in
unexpected ways, and you’ll probably just get frustrated. YMMV.

As Tomas said, if you want better 1.9 support, grab the latest from
GitHub:
http://github.com/ironruby/ironruby and build it:
http://github.com/ironruby/ironruby/wiki/Building

If you run into an issue, the best way to get a response is going to be
to
create a failing test for it, and submit it as an issue, or vote up an
existing issue if it has already been reported, on the CodePlex site:
http://ironruby.codeplex.com/workitem/list/basic?ProjectName=ironruby


Will G.
http://hotgazpacho.org/

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs