Active Record Error

I’ve had to download an existing Rails project and I’m attempting to
setup locally. I’ve installed all the 2.1.1 rails gems needed by the
project as the existing site is at that version. My platform is
Netbeans 6.8 on Windows Vista for development and prod is on linux.
I’ve been able to setup test and other sites using the latetest
version of rails but cant seem to get passed the below exception being

So that’s why I’m email you out of the blue, to which I apologize, but
I’m not seeing any solutions on the web or rails forums and you had
mentioned you work with rails daily and thought you could quickly
identify the problem area.

C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/gems/1.8/gems/
connection_specification.rb:215:in establish_connection': undefined method[]’ for false:FalseClass (NoMethodError)
from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/
abstract/connection_specification.rb:209:in establish_connection' from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/ gems/1.8/gems/rails-2.1.1/lib/initializer.rb:341:ininitialize_database’
from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/
gems/1.8/gems/rails-2.1.1/lib/initializer.rb:124:in process' from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/ gems/1.8/gems/rails-2.1.1/lib/initializer.rb:97:inrun’
from C:/Users/josequinonesii/Websites/
from C:/Users/josequinonesii/Websites/
environment.rb:31:in require' from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/ site_ruby/1.8/rubygems/custom_require.rb:31:inrequire’
from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/
510:in require' ... 9 levels... from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/ gems/1.8/gems/rails-2.1.1/lib/commands/server.rb:31:inrequire’
from C:/Program Files/NetBeans 6.8/ruby2/jruby-1.4.0/lib/ruby/
site_ruby/1.8/rubygems/custom_require.rb:31:in `require’
from script\server:3

My server doesn’t even start up when I attempt to run a local instance
of the site. I can’t seem to find much info for Active Record trouble

I’m connecting locally to a mysql instance and I’m able to connect
with other rails apps running locally.
adapter: mysql
encoding: utf8
database: sterling_local
username: root
password: mylocalpass
host: localhost

For the Ruby flavor what I sent you was a test of JRuby AFTER changing
my configuration settings and ruby platform from Ruby 1.8.6 but I
still get the same error in both flavors of Ruby, which is why it was
ok to send you the exception stack because it was the same error.

I even triple checked the ruby version and gems to ensure I was using
the same version since I can have multiple ruby version installed and
simply explicity reference the required ruby version (i.e.,
RAILS_GEM_VERSION = ‘2.1.1’ unless defined? RAILS_GEM_VERSION) and
I’ve tried 2.2.2 as well as 2.3.5 just to see if I could get it to
work but the same error occurs.

Could there be an issue from developing with gems working on windows
compared to gems working on linux?

Could it be possible that when I downloaded the production site
locally that one of the rb or erb files was corrupt or not completely
downloaded? Other than ftp, is there a better way to download a
production instance locally and setup my dev instance? I simply ftp’ed
all the files and svn repositories to my work station.

Please disregard. The solution was to re-download the site. I’ve got
it working correctly now.