I’ve developed an application last year, deployed it to the web server
and it worked great.
Last week, there were some changes to the hosting plan (changing
username mainly …) but for some reason I am experiencing problems
with an application now (same application that worked before).

The application uses rails 1.2.3. The error that the production log
has is:

ActionView::TemplateError (Expected …/config/…/app/models/product.rb
to define Product) on line #19 of app/views/home/index.rhtml:


Featured Products


    19: <% if Product.valid %>
    20: <% Product.featured.each do |f| %>
  • <%= link_to f.title, :controller => “catalog”, :action
    “show”, :id => %>

  • 22: <% end %>

    Would you know why suddenly it is giving me grief? and/or how to fix


Ok, so on my local machine the site loads fine – no error messages.
Same application on the web server (which worked fine beforehand) –
does not.
I do have SSH access but I am not sure how to get the console on the
web server.

I will contact the web host as well. Any other suggestions as to what
to look for?

On Jul 12, 8:34 pm, Frederick C. [email protected]

On 12 Jul 2008, at 09:03, elle wrote:

ActionView::TemplateError (Expected …/config/…/app/models/product.rb
to define Product) on line #19 of app/views/home/index.rhtml:

That unhelpful message means “something went wrong loading product.rb”.
If you ruby script/console and just type

You should get a better error message.

Hi Elle,

After sshing into your server, you can access the console by doing the
$ /path/to/your/app/script/console production

Note that you may need to change permissions on console to execute it.
$ sudo chmod a+x /path/to/your/app/script/console

If you don’t find a more helpful error message, would you paste your
product.rb file here?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs