Actionrecord gem update produces Zlib::BufError

OS = MS-WinXPproSP2 with hotfixes up to date

Dialogue:

—>
C:>gem update
Updating installed gems…
Bulk updating Gem source index for: http://gems.rubyforge.org
Attempting remote update of actionmailer
Install required dependency actionpack? [Yn] y
Successfully installed actionmailer-1.3.1
Successfully installed actionpack-1.13.1
Installing ri documentation for actionmailer-1.3.1…
Installing ri documentation for actionpack-1.13.1…

lib/action_controller/routing.rb:1050:30: ‘:’ not followed by identified
or oper
ator

lib/action_controller/routing.rb:1054:39: ‘:’ not followed by identified
or oper
ator
Installing RDoc documentation for actionmailer-1.3.1…
Installing RDoc documentation for actionpack-1.13.1…

lib/action_controller/routing.rb:1050:30: ‘:’ not followed by identified
or oper
ator

lib/action_controller/routing.rb:1054:39: ‘:’ not followed by identified
or oper
ator
Attempting remote update of actionpack
Successfully installed actionpack-1.13.1
Installing ri documentation for actionpack-1.13.1…

lib/action_controller/routing.rb:1050:30: ‘:’ not followed by identified
or oper
ator

lib/action_controller/routing.rb:1054:39: ‘:’ not followed by identified
or oper
ator
While generating documentation for actionpack-1.13.1
… MESSAGE: Unhandled special: Special: type=17, text=“SimpleXML”
… RDOC args: --ri --op
c:/usr/local/bin/ruby/lib/ruby/gems/1.8/doc/actionpack-
1.13.1/ri --quiet lib
(continuing with the rest of the installation)
Installing RDoc documentation for actionpack-1.13.1…

lib/action_controller/routing.rb:1050:30: ‘:’ not followed by identified
or oper
ator

lib/action_controller/routing.rb:1054:39: ‘:’ not followed by identified
or oper
ator
Attempting remote update of actionwebservice
Install required dependency activerecord? [Yn] y
ERROR: While executing gem … (Zlib::BufError)
buffer error

C:>

<—

I googled for this and came up with previous messages relating to a
discrepancy in gem file sizes when going from rails-1.1.5 to 1.1.6 but
nothing about rails-1.2.1. I have RubyZib installed. How do I get this
fixed or bypassed?

Thanks.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs