ActionMailer timeout problems


#1

Hi,

I am having problems getting ActionMailer to send any mail.
I am developing on windows XP with lighttpd and scgi.

my settings are as follows(my.domain.net is replaced with a correct mail
server):
config.action_mailer.server_settings = {
:address => “my.domain.net”,
:port => 25,
:domain => “domain.net
}
config.action_mailer.raise_delivery_errors = true

The mail server does not require authentication.

The error I get is:
c:/ruby/lib/ruby/1.8/timeout.rb:54:in rbuf_fill': execution expired (Timeout::E rror) from c:/ruby/lib/ruby/1.8/timeout.rb:56:intimeout’
from c:/ruby/lib/ruby/1.8/timeout.rb:76:in timeout' from c:/ruby/lib/ruby/1.8/net/protocol.rb:132:inrbuf_fill’
from c:/ruby/lib/ruby/1.8/net/protocol.rb:116:in readuntil' from c:/ruby/lib/ruby/1.8/net/protocol.rb:126:inreadline’
from c:/ruby/lib/ruby/1.8/net/smtp.rb:664:in recv_response' from c:/ruby/lib/ruby/1.8/net/smtp.rb:396:indo_start’
from c:/ruby/lib/ruby/1.8/net/smtp.rb:686:in critical' from c:/ruby/lib/ruby/1.8/net/smtp.rb:396:indo_start’
from c:/ruby/lib/ruby/1.8/net/smtp.rb:378:in start' from c:/ruby/lib/ruby/1.8/net/smtp.rb:316:instart’
from
c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-1.2.1/lib/action_mailer
/base.rb:447:in perform_delivery_smtp' from c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-1.2.1/lib/action_mailer /base.rb:333:indeliver!’
from
c:/ruby/lib/ruby/gems/1.8/gems/actionmailer-1.2.1/lib/action_mailer
/base.rb:227:in method_missing' from (irb):2:inirb_binding’
from c:/ruby/lib/ruby/1.8/irb/workspace.rb:52:in `irb_binding’
from c:/ruby/lib/ruby/1.8/irb/workspace.rb:52

netstat doesn’t show any connection attempt to the mail server being
made.

Any help would be appreciated!


#2

I am having problems getting ActionMailer to send any mail.
I am developing on windows XP with lighttpd and scgi.

I would try first seeing if you can do it from a telnet session. Check
out
this page for help:

http://www.garnetchaney.com/how_to_telnet_to_a_mail_server.shtml


#3

Thanks for the response.

Telnet works fine. I can also send mail using Thunderbird, etc.
I’ve also tried using an IP address for :address as well, in case of DNS
problems, to no avail.

Daniel T. wrote:

I am having problems getting ActionMailer to send any mail.
I am developing on windows XP with lighttpd and scgi.

I would try first seeing if you can do it from a telnet session. Check
out
this page for help:

http://www.garnetchaney.com/how_to_telnet_to_a_mail_server.shtml