Actionmailer-SSL-Fehlermeldung


#1

Hallo,

vielleicht kann mir jemand weiterhelfen. Beim Versand von Emails streikt
der
ActionMailer unter Rails 2.2.2 auf einmal.

Im Log steht:

Sent mail to removed_email_address@domain.invalid

OpenSSL::SSL::SSLError (hostname was not match with the server
certificate):
/usr/local/lib/ruby/1.8/openssl/ssl.rb:123:in
post_connection_check' /usr/local/lib/ruby/1.8/net/smtp.rb:582:intlsconnect’
/usr/local/lib/ruby/1.8/net/smtp.rb:562:in do_start' /usr/local/lib/ruby/1.8/net/smtp.rb:525:instart’

Ich hab’ mal etwas rumgegoogelt, aber so ganz klar ist mir nicht, was
ich jetzt
zur Behebung dieser Meldung machen soll.

Brauche ich jetzt ein SSL-Zertifikat?

Viele
Grüße
Michael K.


#2

On Thu, 26 Feb 2009 19:09:37 +0100
Michael K. removed_email_address@domain.invalid wrote:

Hallo,

hi

 /usr/local/lib/ruby/1.8/net/smtp.rb:582:in `tlsconnect'
 /usr/local/lib/ruby/1.8/net/smtp.rb:562:in `do_start'
 /usr/local/lib/ruby/1.8/net/smtp.rb:525:in `start'

Ich hab’ mal etwas rumgegoogelt, aber so ganz klar ist mir nicht, was ich jetzt
zur Behebung dieser Meldung machen soll.

Brauche ich jetzt ein SSL-Zertifikat?

sieht ganz danach aus.
oder aber du verhinderst tls-initialisation:
per default scheint eingestellt:

:enable_starttls_auto => true wenn das ziel das
unterstützt.
ein ‘false’ und er würde keinen tls-handshake versuchen, die ssl-meldung also
verschwinden.

theoretisch glaube ich also:

ActionMailer::Base.smtp_settings = {
:enable_starttls_auto => false
}

gruesse
rene


#3

ActionMailer::Base.smtp_settings = {
:enable_starttls_auto => false
}

Diese Option gibt es erst ab V2.3

ansonsten hier nachlesen:

http://www.travisgere.com/?p=34

oder Monkey-patchen:

http://rails.lighthouseapp.com/projects/8994/tickets/1731-make-enable_starttls_auto-opt-in-in-actionmailer#ticket-1731-9

Gruss,
Roman

Am 26.02.2009 um 19:37 schrieb Rene P.:


#4

Hallo Roman,

das hat mir jetzt wirklich das Wochenende gerettet. “Monkey-Patch”, den
Ausdruck
kannte ich noch garnicht. Gleich zwei Dinge gelernt.

Der Patch funktioniert jedenfalls.

Viele Grüße und besten Dank

Michael K.

Roman Sladeczek schrieb: