ActionMailer how to check mail sent

OS X 10.4.8

I am sending an email via Actionmailer

settings are written correctly in environment.rb
ActionMailer::Base.delivery_method = :smtp
ActionMailer::Base.raise_delivery_errors = :true
ActionMailer::Base.perform_deliveries = :true
ActionMailer::Base.default_charset = “utf-8”
ActionMailer::Base.server_settings = {
:address => “mail.mydomain.com”,
:port => 25,
:domain => “mydomain.com”,
:user_name => “myusername”,
:password => “mypassword”,
:authentication => :login
}

functional test are good… mail sent

development.log contains the correct mail :
Sent mail:
Date: Tue, 31 Oct 2006 18:17:32 +0100
From: [email protected]
To: [email protected]
Subject: PDM Test Site - Activez votre enregistrement dans PDM
Content-Type: text/plain; charset=utf-8
You are now registered :
ID: yves
Password: eddy
clic on the following url to …

no errors… but no mail received by [email protected]… how can I check
that’s something is wrong
thanks for your help
Kad

Kad K. wrote:

no errors… but no mail received by [email protected]… how can I check
that’s something is wrong
thanks for your help
Kad

The process I follow for e-mail delivery issues here is:

  1. Check your app output/log. (done, no errors)
  2. Check your smtp server log to see that it went out the door with no
    errors.
  3. Get the intended recipient involved and check for spam filters on
    their mail server, your domain being blacklisted on their mail server,
    spam filters and other redirection in their e-mail client, etc., etc.
    This is usually the problem.

One thing that might also help is BCC’ing an external e-mail account of
your own on everything you send out. If you get it and the other
intended recipient doesn’t, I think that’s a pretty good indication that
the problem is on their end somewhere.

Kad K. wrote:

OS X 10.4.8

I am sending an email via Actionmailer

settings are written correctly in environment.rb
ActionMailer::Base.delivery_method = :smtp
ActionMailer::Base.raise_delivery_errors = :true
ActionMailer::Base.perform_deliveries = :true
ActionMailer::Base.default_charset = “utf-8”
ActionMailer::Base.server_settings = {
:address => “mail.mydomain.com”,
:port => 25,
:domain => “mydomain.com”,
:user_name => “myusername”,
:password => “mypassword”,
:authentication => :login
}

functional test are good… mail sent

development.log contains the correct mail :
Sent mail:
Date: Tue, 31 Oct 2006 18:17:32 +0100
From: [email protected]
To: [email protected]
Subject: PDM Test Site - Activez votre enregistrement dans PDM
Content-Type: text/plain; charset=utf-8
You are now registered :
ID: yves
Password: eddy
clic on the following url to …

no errors… but no mail received by [email protected]… how can I check
that’s something is wrong
thanks for your help
Kad
Check the following -

  1. Have you checked if your ISP is blocking port 25? Many ISPs routinely
    block that port to prevent people from putting up their own SMTP servers
    as a spam prevention measure. In this case you will need to use their
    SMTP server.

  2. SMTP servers can have added security settings. For example, my ISP
    (cox) does not like it if I specify username or password. But they need
    a non-blank string in the “domain” field. I ended up putting a random
    string to get it to work.

  3. Is your “From:” address a real one? Some SMTP servers will check if
    this is a valid email or deny relaying messages otherwise.

Hope this helps. Do let us know how you resolved your problem.

Chet wrote:

Kad K. wrote:

OS X 10.4.8
in environment.rb
ActionMailer::Base.delivery_method = :smtp
ActionMailer::Base.raise_delivery_errors = :true
ActionMailer::Base.perform_deliveries = :true
ActionMailer::Base.default_charset = “utf-8”
ActionMailer::Base.server_settings = {
:address => “mycomputername.local”,
:port => 25,
:domain => “local”,
}
Hope this helps. Do let us know how you resolved your problem.

thank to all… it’s up and running…
I setup a localhost smtp server
postfix setup is quite easy…
in etc/postfix/main.cf
myhostname = localhost.localdomain
mydomain = localdomain
mynetworks_style = host
in etc/postfix/master.cf
smtp inet n - n - -
smtpd
to start : sudo postfix start
to stop : sudo postfix stop

AND taking care of writing a valid sender domain name… in my
user.notifier.rb @from = [email protected]_domain_name

et voilÃ

thanks again for your clue ! (all rails stuff were correct…)

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs