Action_profiler choking on Rails 1.2.2

Hi All,

I’m having trouble getting action_profiler (http://rails-
analyzer.rubyforge.org/action_profiler/) running on my app. I am
running on Rails 1.2.2, and am using ActiveRecordStore to store my
sessions. I’ve included the dump below…

Thanks in advance.
Mark

$ action_profiler MyController#index
/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/active_support/
dependencies.rb:477:in const_missing': uninitialized constant CGI::Session::ActiveRecordStore (NameError) from /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.2/lib/ action_controller/session_management.rb:22:insession_store=’
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/
initializer.rb:328:in initialize_framework_settings' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/ initializer.rb:327:ininitialize_framework_settings’
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/
initializer.rb:324:in initialize_framework_settings' from /usr/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/ initializer.rb:96:inprocess’
from /usr/lib/ruby/gems/1.8/gems/rails-1.2.2/lib/
initializer.rb:43:in run' from ./config/environment.rb:10 from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb: 21:inrequire’
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/dependencies.rb:495:in require' from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/ active_support/dependencies.rb:342:innew_constants_in’
from /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.1/lib/
active_support/dependencies.rb:495:in require' from /usr/lib/ruby/gems/1.8/gems/action_profiler-1.0.0/lib/ action_profiler/profiled_processor.rb:89:inprocess_args’
from /usr/lib/ruby/gems/1.8/gems/action_profiler-1.0.0/bin/
action_profiler:5
from /usr/bin/action_profiler:18