Act as Taggable with Rails 2.0

I’ve posted a different question just before – but before I can try
and get a better idea of my error message, I was trying to start my
application and ran into other problems.
My application was developed last year in rails 1.2.3. I since
upgraded my computer and have the latest version of rails. When I
tried to star the application I got the following error message:

/…/config/environment.rb:62: undefined method require_gem' for main:Object (NoMethodError) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:ingem_original_require’

my environment.rb: 62 has:
require_gem ‘acts_as_taggable’
which I know isn’t compatible

Would anyone have a suggestion on how to solve this?

Thanks
Elle

Hi elle,
require_gem method has been deprecated. use simply ‘require’.

Thanks,
-Sadeesh kumar

Changing it to ‘require’ I now get the following error message:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_require': no such file to load -- acts_as_taggable (MissingSourceFile) from /usr/local/lib/ruby/site_ruby/1.8/rubygems/ custom_require.rb:27:inrequire’

I did install the gem. Should I install/update it?
Thanks,
Elle

Yep, that worked. Thanks Fred.

Elle

On Jul 13, 8:02 am, Frederick C. [email protected]

On 12 Jul 2008, at 20:14, elle wrote:

Changing it to ‘require’ I now get the following error message:

Actually require_gem should be replaced with gem

Fred

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs