Accessing fixtures in tests

hi all,

my first attempt at tests and i’m having trouble accessing the
fixture values, if anyone can make it suggestions.

i have news_release_test.rb, using new_releases.yml as the fixture file

according to the agile book, i should be able to access the fixture
properties within my test as such:

assert_equal ,

unfortunately, i try that and get:

RuntimeError: Called id for nil, which would mistakenly be 4 – if
you really wanted the id of nil, use object_id”

after looking on, i saw and tried this:


and now i get the following error:

“NoMethodError: You have a nil object when you didn’t expect it!
You might have expected an instance of Array.
The error occured while evaluating nil.[]”

thanks in advance,

All the best,

Matthew Collins
Senior Developer
MindComet Corporation

Orlando ? Atlanta ? New York

Corporate Blog -
Culture Blog -

The Relationship Agency?
2701 Maitland Center Parkway, Suite 125
Maitland, FL 32751

v 800.668.1761 x316
f 407.838.1011

AIM mattatmindcomet

The information contained in this e-mail message may be privileged and
confidential. If you are not the intended recipient, any further
disclosure or use, distribution, or copying of this message or any
attachment is strictly prohibited. If you have received this e-mail
message in error, please delete the e-mail, and either e-mail the sender
at the above address or notify us at our telephone number 407.838.1010.
Internet e-mail may be subject to delays, non-delivery and unauthorized
alterations, therefore opinions, conclusions and other information
expressed are not binding upon MindComet Corporation unless otherwise
notified independently of this message.


In your test_helper.rb file have you got…
self.use_instantiated_fixtures = true

yeah, that fixed it.