Access denied for user

Hi i only just started trying to use ruby 3 days ago, but i got stuck
about 1 day into my exploration. Ruby is tuff for first timers, i’ve
never had to work this hard to to get up and running, but i guess it
can’t all be easy. i’m more determined now.
I’m running Uniserver3.3 WAMP package. I’ve been following the tut on
the onLamp site ‘cookbook’. It seems pretty good for beginners, but
doesn’t offer much in the way of troubleshooting these problems. My .yml
file looks in order but if i change the username from root to another
user i still get the same error, which is confusing. I don’t know enough
about ruby to troubleshoot this on my own so i’ve turned to your forum
for a few pointers.
the full message appears below and it never changes no matter what i do
to the .yml file even removing it.
Mysql::Error in Phonebook#index
Access denied for user ‘root’@‘localhost’ (using password: NO)
RAILS_ROOT: ./script/…/config/…
if there is a great tutorial i should read before trying to learn ruby
or a thread in this forum which could answer my question i’ve got lots
of time to go reading, but it always feels like time wasted when you
don’t make progress. Does the error atleast indicate that ruby knows
where the DB is? Is there another file which is being read that i’m not
aware of(reason why the error never changes)?

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs