About qt4-ruby


#1

Hi,
Today I compiled qt4-ruby in my rhel5 box. And have a little test.
Well, when the .rb runs, it says something wrong from qtruby4.so,
libsmokeqt.so.2 does not have symbol of _ZN8QWebView11qt_metacastEPKc.
I recompiled qt4 with -webkit option, and qt4-ruby. Not helping.


#2

Alle Wednesday 17 December 2008, Magicloud ha scritto:

Hi,
Today I compiled qt4-ruby in my rhel5 box. And have a little test.
Well, when the .rb runs, it says something wrong from qtruby4.so,
libsmokeqt.so.2 does not have symbol of _ZN8QWebView11qt_metacastEPKc.
I recompiled qt4 with -webkit option, and qt4-ruby. Not helping.

It’s smoke which doesn’t have the symbol, not qt itself, so you’ll need
to
recompile smoke, and maybe also qtruby itself too.

Stefano


#3

Stefano C. wrote:

recompile smoke, and maybe also qtruby itself too.

Stefano

So may I know how to compile smoke? I read smoke/README, and ran the
four commands in it, which gave me a new libsmokeqt.so, which still does
not work.


#4

Alle Thursday 18 December 2008, Magicloud ha scritto:

Stefano

So may I know how to compile smoke? I read smoke/README, and ran the
four commands in it, which gave me a new libsmokeqt.so, which still does
not work.

If you mean the commands:

cd qt
./qtguess.pl
./generate.pl
make

they’re not enough. As the README states, they’re only to generate the
.cpp
files. What you need is the following:

  • go in the top level directory of qtruby
  • mkdir build
  • cd build
  • cmake …
  • make
  • sudo make install

This will install qtruby4 in /usr/local (excluding the ruby bindings
themselves, which will be installed in /usr/lib/ruby/site_ruby/1.8 (or
something like this, depending on whether ruby itself is installed). If
you
want to install it somewhere else, replace the cmake … command with

cmake -DCMAKE_INSTALL_PREFIX=/path/to/install/dir …

I think this should solve your problem. If you have other questions
about
qtruby, you can post them in the qtruby forum, which you can find at
http://rubyforge.org/projects/korundum, where you’ll be more likely to
get an
answer (and a better one, too, since there questions are answered by the
developers themselves).

I hope this helps

Stefano


#5

Stefano C. wrote:

I recompiled qt4 with -webkit option, and qt4-ruby. Not helping.
  • mkdir build
    cmake -DCMAKE_INSTALL_PREFIX=/path/to/install/dir …

I used kdebindings instead of qt4-ruby, everything is fine now.
Thanks.