About importerror in gnuradio 3.7.0

Dear list,

I want to move my out of tree model from gnuradio 3.6.5 to 3.7.0. I
follow the introduction about how to move from 3.6 to 3.7. The code is
able to build. However when I running the python script, still meet the
importerror as follow:

ImportError: /usr/local/lib/libgnuradio-gmsktr.so: undefined symbol:
_ZN2gr6filter24mmse_fir_interpolator_ffC1Ev

I have tried two days to find the bug but no progress…does somebody
have experience about this problem? Any suggestions would be
appreciated!

Best regards

Alex

On Mon, Dec 09, 2013 at 10:15:06AM +0100, alex wrote:

be appreciated!
What exactly did you try? What’s your GR version?
Have you read
http://gnuradio.org/redmine/projects/gnuradio/wiki/OutOfTreeModulesConfig?

MB


Karlsruhe Institute of Technology (KIT)
Communications Engineering Lab (CEL)

Dipl.-Ing. Martin B.
Research Associate

Kaiserstraße 12
Building 05.01
76131 Karlsruhe

Phone: +49 721 608-43790
Fax: +49 721 608-46071
www.cel.kit.edu

KIT – University of the State of Baden-Württemberg and
National Laboratory of the Helmholtz Association

On Mon, Dec 9, 2013 at 6:15 AM, Martin B. (CEL)
[email protected] wrote:

somebody have experience about this problem? Any suggestions would
be appreciated!

What exactly did you try? What’s your GR version?
Have you read
http://gnuradio.org/redmine/projects/gnuradio/wiki/OutOfTreeModulesConfig?

MB

Also, check out the page explaining the differences between 3.6 and
3.7 to help you relocate where things are:

http://gnuradio.org/redmine/projects/gnuradio/wiki/Move_3-6_to_3-7

Tom

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs