A small error in benchmark_tx file

Hi all,
I have been trying to send data between 2 USRP’s from the benchmark_tx
file only to observe that I have been receiving this error.

Traceback (most recent call last):
File “./benchmark_tx.py”, line 147, in
main()
File “./benchmark_tx.py”, line 111, in main
tb = my_top_block(mods[options.modulation], options)
File “./benchmark_tx.py”, line 49, in init
options.antenna, options.verbose)
File
“/usr/local/share/gnuradio/examples/digital/narrowband/uhd_interface.py”,
line 135, in init
freq, gain, antenna)
File
“/usr/local/share/gnuradio/examples/digital/narrowband/uhd_interface.py”,
line 62, in init
self._rate, self._sps = self.set_sample_rate(bitrate, sps)
File
“/usr/local/share/gnuradio/examples/digital/narrowband/uhd_interface.py”,
line 70, in set_sample_rate
asked_samp_rate = bitrate * req_sps
TypeError: unsupported operand type(s) for *: ‘float’ and ‘NoneType’

I am unable to understand what this error means? I have tried to search
in the Internet about this but found nothing relevant. Please advice as
to what I can do?

Thanks,
Dave

Please help so that I can proceed further as I am new to GNU Radio.

Thanks,
Dave

Can anyone please give an answer for the above error?

Thanks,
Dave

Hi Dave,

it’s monday, and most of us haven’t gotten around answering emails from
the weekend, so please accept my apologies for not having exploding
enthusiasm when I saw your first reminder five hours after you posted
your question :wink:

So, first of all: thanks for the bug report! It’s always good to
eradicate errors.

Which version of GNU Radio are you using (run “gnuradio-config-info
–version”)? I think it must be at least from 2013 or older, if these
line numbers are correct, but I could be mistaken. If your GNU Radio is
in fact as old as that, could you try with a newer version, and see
whether that works?

To try locally, we’d need the actual command line that you’re executing.

Best regards,
Marcus

PS: One thing: I’m grumpy sometimes, sorry. Also, please sign up with an
email address under
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio ; ruby-forum has
lead to numerous problems on this mailing list, because it is an
extraordinarily bad mailing list interface, shamelessly using the
mails that we send here.

Hi Dave,

Firstly, please sign up and post to the GNU Radio mailing list via the
official method, not the Ruby forum. GNU Radio has nothing to do with
Ruby!

Official GNU Radio mailing list sign-up link:

https://lists.gnu.org/mailman/listinfo/discuss-gnuradio

In regard to your question, make sure you specify all parameters on the
command line, especially frequency, lo-offset and antenna to see whether
that fixes it for you. I believe the ‘none-type’ error pops up because
some parameter hasn’t been specified and the empty parameter isn’t error
checked/initialised to ‘0’ correctly if not specified on the command
line.
This may be related to the following bug:

https://gnuradio.org/redmine/issues/705

Mike


Mike J. M0MIK BSc MIET
Email: [email protected]
Web: http://scanoo.com

Ha, ok, so I was mistaken regarding the version 3.7.7 is relatively
recent!
Sanity check: the benchmark_tx and all other files in that directory
came with your version GNU Radio, and you did not download them
elsewhere, right?

Have you tried “./benchmark_tx --help”, and then specifying things like
samples per symbol and sampling rate manually?

Best regards,
Marcus

Thanks for the reply. I really appreciate it. I have subscribed to the
mailing list. And in regard to my question, I have given the command and
it has popped up this line

gnuradio-config-info --version
v3.7.7.1-198-g9e133ccb

I am not sure of what version the GNU Radio it can be? The command I
have given was " ./benchmark_tx.py -f 2.435G " and it pops up the above
error. But if I do the same thing for ./benchmark_rx.py -f 2.435G, it
shows no error and waits for transmitter to transmit the packets.
And also can I please attach my benchmark files so that you might be
able to view those.

Thanks,
Dave

Yes, I tried that. Regarding the former question, I guess I have kept
all the files in that manner but I downloaded recent files of
benchmark_tx.py and uhd_interface.py files as far as I remember.
Regarding the latter, I was not able to give manually because I did not
know as to exactly what sampling rate and how many samples per symbol I
can insert. Please help with this. I have posted this in mailing list
too.

Thanks,
Dave

Dave,
this might look strange to the afterworld, but:
Are you Ravi?

Best regards,
Marcus

I am sorry. No

Hi Dave,
Don’t be sorry :slight_smile:

However, of you’ve modified the scripts yourself, there’s no way for
anyone but you to find out what goes wrong. Can you save your
modifications somewhere else, and overwrite all potentially modified
scripts with their original version?
Ravi has a very similar case, and I recommended not installing over
everything if Ravi knew where the originals are. If you don’t know,
reinstalling might be the easiest way to get the originals.

Best regards,
Marcus

PS: I’ll stop answering emails from Ruby forum now, and wait till you
send them from your regular email account

Am 8. September 2015 00:13:30 MESZ, schrieb Dave Allen
[email protected]:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs