A problem with ALSA


#1

Hi,

I’m also tring to making some sound out of the USRP box, however, even
test with the most simple script to generate a dial tone given by
http://www.gnu.org/software/gnuradio/doc/exploring-gnuradio.html
the alsa seems can not work as expected. I could listen to music
successfully under my Ubuntu 7.04 and gnuradio-alsa is successfully
configured and compiled. I’ve checked some old maillist record to
solve this problem but nothing helps. And I’m not using any music
player at the same time when test the python script (Maybe my Ubuntu
occupies it? I don’t know…)

Hope here someone encountered the same newbie question as mine~ :slight_smile:

===========================================

audio_alsa_sink[hw:0,0]: Device or resource busy
Traceback (most recent call last):
File “./dial_tone.py”, line 20, in
fg = build_graph ()
File “./dial_tone.py”, line 13, in build_graph
dst = audio.sink (sampling_freq)
File “/usr/local/lib/python2.5/site-packages/gnuradio/audio_alsa.py”,
line 236, in sink
return _audio_alsa.sink(*args)
RuntimeError: audio_alsa_sink


#2

Check the running processes. If there are any sound daemons such as esd
running, kill them and give it another try.

Frank

??? (Yuankai Ge) wrote:

occupies it? I don’t know…)
dst = audio.sink (sampling_freq)


Managing developers is like herding cats.
Managing volunteer developers is like herding bats, in the dark.


#3

Greetings.
I had the same error messages, but followed the instructions at
http://ubuntuforums.org/showthread.php?t=32063
and everything now seems to work. I’m too new to all this to explain
how or
why it solved the problem, but suggest you give it a try and see if your
apps will run.
All the best,
Kevin

葛元恺 (Yuankai Ge) wrote:

player at the same time when test the python script (Maybe my Ubuntu
File “./dial_tone.py”, line 13, in build_graph
http://lists.gnu.org/mailman/listinfo/discuss-gnuradio


View this message in context:
http://www.nabble.com/A-problem-with-ALSA-tf4076336.html#a11591178
Sent from the GnuRadio mailing list archive at Nabble.com.